Potential Authorization Header Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
NestJS Proxy is a NestJS module to decorate and proxy calls. Prior to version 0.7.0, the nestjs-proxy library did not have a way to control when Authorization headers should should be forwarded for specific backend services configured by the application developer. This could have resulted in sensitive information such as OAuth bearer access tokens being inadvertently exposed to such services that should not see them. A new feature has been introduced in the patched version of nestjs-proxy that allows application developers to opt out of forwarding the Authorization headers on a per service basis using the `forwardToken` config setting. Developers are advised to review the README for this library on Github or NPM for further details on how this configuration can be applied. This issue has been fixed in version 0.7.0 of `@finastra/nestjs-proxy`. Users of `@ffdc/nestjs-proxy` are advised that this package has been deprecated and is no longer being maintained or receiving updates. Such users should update their package.json file to use `@finastra/nestjs-proxy` instead.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Finastra | finastra-nodejs-libs | before 0.7.0 | 0.7.0 | Patch available | CNA |
| — | @finastra/nestjs-proxy (npm) | before 0.7.0 | 0.7.0 | Patch available | GHSA-j562-c3cw-3p5g |
- finastra-nodejs-libs VendorFinastra Affected before 0.7.0 Fixed in 0.7.0 Patch available CNA
- @finastra/nestjs-proxy (npm) Vendor— Affected before 0.7.0 Fixed in 0.7.0 Patch available GHSA-j562-c3cw-3p5g
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:finastra:nestjs-proxy:*:*:*:*:*:node.js:*:* | before 0.7.0 | Vulnerable | Finastra |
| cpe:2.3:a:nestjs-proxy_project:nestjs-proxy:*:*:*:*:*:node.js:*:* | up to 0.4.0 | Vulnerable | Nestjs-proxy Project |
- cpe:2.3:a:finastra:nestjs-proxy:*:*:*:*:*:node.js:*:* Versions before 0.7.0 Vulnerable ·Finastra
- cpe:2.3:a:nestjs-proxy_project:nestjs-proxy:*:*:*:*:*:node.js:*:* Versions up to 0.4.0 Vulnerable ·Nestjs-proxy Project
Remediation
- Fix · CNA finastra-nodejs-libs (Finastra) Fixed in 0.7.0
- Fix · GHSA-j562-c3cw-3p5g @finastra/nestjs-proxy (npm) Fixed in 0.7.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31069
- 2026-10-03 Alias added: GHSA-j562-c3cw-3p5g
- 2026-10-16 EPSS moved to the 50th–90th percentile
References
More Finastra Nestjs-proxy vulnerabilities
- TI-2022-13114 Potential Sensitive Cookie Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy CVSS 3.1HIGH 7.5
Sources
- CVE-2022-31069 · CVE Program
- CVE-2022-31069 · NVD
- FIRST EPSS
- GHSA-j562-c3cw-3p5g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences