Potential Sensitive Cookie Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
NestJS Proxy is a NestJS module to decorate and proxy calls. Prior to version 0.7.0, the nestjs-proxy library did not have a way to block sensitive cookies (e.g. session cookies) from being forwarded to backend services configured by the application developer. This could have led to sensitive cookies being inadvertently exposed to such services that should not see them. The patched version now blocks cookies from being forwarded by default. However developers can configure an allow-list of cookie names by using the `allowedCookies` config setting. This issue has been fixed in version 0.7.0 of `@finastra/nestjs-proxy`. Users of `@ffdc/nestjs-proxy` are advised that this package has been deprecated and is no longer being maintained or receiving updates. Such users should update their package.json file to use `@finastra/nestjs-proxy` instead.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Finastra | finastra-nodejs-libs | before 0.7.0 | 0.7.0 | Patch available | CNA |
| — | @finastra/nestjs-proxy (npm) | before 0.7.0 | 0.7.0 | Patch available | GHSA-77mv-4rg7-r8qv |
- finastra-nodejs-libs VendorFinastra Affected before 0.7.0 Fixed in 0.7.0 Patch available CNA
- @finastra/nestjs-proxy (npm) Vendor— Affected before 0.7.0 Fixed in 0.7.0 Patch available GHSA-77mv-4rg7-r8qv
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:finastra:nestjs-proxy:*:*:*:*:*:node.js:*:* | before 0.7.0 | Vulnerable | Finastra |
| cpe:2.3:a:nestjs-proxy_project:nestjs-proxy:*:*:*:*:*:node.js:*:* | up to 0.4.0 | Vulnerable | Nestjs-proxy Project |
- cpe:2.3:a:finastra:nestjs-proxy:*:*:*:*:*:node.js:*:* Versions before 0.7.0 Vulnerable ·Finastra
- cpe:2.3:a:nestjs-proxy_project:nestjs-proxy:*:*:*:*:*:node.js:*:* Versions up to 0.4.0 Vulnerable ·Nestjs-proxy Project
Remediation
- Fix · CNA finastra-nodejs-libs (Finastra) Fixed in 0.7.0
- Fix · GHSA-77mv-4rg7-r8qv @finastra/nestjs-proxy (npm) Fixed in 0.7.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31070
- 2026-10-03 Alias added: GHSA-77mv-4rg7-r8qv
- 2026-10-16 EPSS moved to the 50th–90th percentile
References
More Finastra Nestjs-proxy vulnerabilities
- TI-2022-13113 Potential Authorization Header Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy CVSS 3.1HIGH 7.5
Sources
- CVE-2022-31070 · CVE Program
- CVE-2022-31070 · NVD
- FIRST EPSS
- GHSA-77mv-4rg7-r8qv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences