Invalid file request can crashe parse-server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In affected versions certain types of invalid files requests are not handled properly and can crash the server. If you are running multiple Parse Server instances in a cluster, the availability impact may be low; if you are running Parse Server as single instance without redundancy, the availability impact may be high. This issue has been addressed in versions 4.10.12 and 5.2.3. Users are advised to upgrade. There are no known workarounds for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | before 4.10.12; 5.0.0 to before 5.2.3 | 4.10.12, 5.2.3 | Patch available | CNA |
| — | parse-server (npm) | before 4.10.12 | 4.10.12 | Patch available | GHSA-xw6g-jjvf-wwf9 |
| — | parse-server (npm) | 5.0.0 to before 5.2.3 | 5.2.3 | Patch available | GHSA-xw6g-jjvf-wwf9 |
- parse-server Vendorparse-community Affected before 4.10.12; 5.0.0 to before 5.2.3 Fixed in 4.10.12, 5.2.3 Patch available CNA
- parse-server (npm) Vendor— Affected before 4.10.12 Fixed in 4.10.12 Patch available GHSA-xw6g-jjvf-wwf9
- parse-server (npm) Vendor— Affected 5.0.0 to before 5.2.3 Fixed in 5.2.3 Patch available GHSA-xw6g-jjvf-wwf9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 4.10.12; 5.0.0 to before 5.2.3 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 4.10.12; 5.0.0 to before 5.2.3 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 4.10.12, 5.2.3
- Fix · GHSA-xw6g-jjvf-wwf9 parse-server (npm) Fixed in 4.10.12 Advisory →
- Fix · GHSA-xw6g-jjvf-wwf9 parse-server (npm) Fixed in 5.2.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31089
- 2026-10-03 Alias added: GHSA-xw6g-jjvf-wwf9
References
Patch 1
Advisory 2
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2022-31089 · CVE Program
- CVE-2022-31089 · NVD
- FIRST EPSS
- GHSA-xw6g-jjvf-wwf9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences