Protected fields exposed via LiveQuery in parse-server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In affected versions parse Server LiveQuery does not remove protected fields in classes, passing them to the client. The LiveQueryController now removes protected fields from the client response. Users are advised to upgrade. Users unable t upgrade should use `Parse.Cloud.afterLiveQueryEvent` to manually remove protected fields.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | before 4.10.13; 5.0.0 to before 5.2.4 | 4.10.13, 5.2.4 | Patch available | CNA |
| — | parse-server (npm) | before 4.10.13 | 4.10.13 | Patch available | GHSA-crrq-vr9j-fxxh |
| — | parse-server (npm) | 5.0.0 to before 5.2.4 | 5.2.4 | Patch available | GHSA-crrq-vr9j-fxxh |
- parse-server Vendorparse-community Affected before 4.10.13; 5.0.0 to before 5.2.4 Fixed in 4.10.13, 5.2.4 Patch available CNA
- parse-server (npm) Vendor— Affected before 4.10.13 Fixed in 4.10.13 Patch available GHSA-crrq-vr9j-fxxh
- parse-server (npm) Vendor— Affected 5.0.0 to before 5.2.4 Fixed in 5.2.4 Patch available GHSA-crrq-vr9j-fxxh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 4.10.13; 5.0.0 to before 5.2.4 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 4.10.13; 5.0.0 to before 5.2.4 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 4.10.13, 5.2.4
- Fix · GHSA-crrq-vr9j-fxxh parse-server (npm) Fixed in 4.10.13 Advisory →
- Fix · GHSA-crrq-vr9j-fxxh parse-server (npm) Fixed in 5.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31112
- 2026-10-03 Alias added: GHSA-crrq-vr9j-fxxh
References
Patch 4
- https://github.com/parse-community/parse-server/issues/8073
- https://github.com/parse-community/parse-server/pull/8074
- https://github.com/parse-community/parse-server/commit/309f64ced8700321df056fb3cc97f15007a00df1
- https://github.com/parse-community/parse-server/commit/9fd4516cde5c742f9f29dd05468b4a43a85639a6
Advisory 3
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2022-31112 · CVE Program
- CVE-2022-31112 · NVD
- FIRST EPSS
- GHSA-crrq-vr9j-fxxh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences