Use of a Broken or Risky Cryptographic Algorithm in packbackbooks/lti-1-3-php-library
Priority LOW 39CWE-327Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-327.
Summary
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the function used to generate random nonces was not sufficiently cryptographically complex. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00453 39th percentileScored 2026-11-07
Fix Fixed lti-1-3-php-library (packbackbooks): 5.0packbackbooks/lti-1-3-php-library (Packagist): 5.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| packbackbooks | lti-1-3-php-library | before 5.0 | 5.0 | Patch available | CNA |
| — | packbackbooks/lti-1-3-php-library (Packagist) | before 5.0 | 5.0 | Patch available | GHSA-768m-5w34-2xf5 |
- lti-1-3-php-library Vendorpackbackbooks Affected before 5.0 Fixed in 5.0 Patch available CNA
- packbackbooks/lti-1-3-php-library (Packagist) Vendor— Affected before 5.0 Fixed in 5.0 Patch available GHSA-768m-5w34-2xf5
Remediation
- Fix · CNA lti-1-3-php-library (packbackbooks) Fixed in 5.0
- Fix · GHSA-768m-5w34-2xf5 packbackbooks/lti-1-3-php-library (Packagist) Fixed in 5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31157
- 2026-10-03 Alias added: GHSA-768m-5w34-2xf5
References
Advisory 2
More Packback Lti 1.3 Tool Library vulnerabilities
- TI-2022-13201 Authentication Bypass by Capture-replay in packbackbooks/lti-1-3-php-library CVSS 3.1HIGH 7.5
Sources
- CVE-2022-31157 · CVE Program
- CVE-2022-31157 · NVD
- FIRST EPSS
- GHSA-768m-5w34-2xf5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences