Authentication Bypass by Capture-replay in packbackbooks/lti-1-3-php-library
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Information disclosure
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-294 and CWE-327.
Summary
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| packbackbooks | lti-1-3-php-library | before 5.0 | 5.0 | Patch available | CNA |
| — | packbackbooks/lti-1-3-php-library (Packagist) | before 5.0 | 5.0 | Patch available | GHSA-5p73-qg2v-383h |
- lti-1-3-php-library Vendorpackbackbooks Affected before 5.0 Fixed in 5.0 Patch available CNA
- packbackbooks/lti-1-3-php-library (Packagist) Vendor— Affected before 5.0 Fixed in 5.0 Patch available GHSA-5p73-qg2v-383h
Remediation
- Fix · CNA lti-1-3-php-library (packbackbooks) Fixed in 5.0
- Fix · GHSA-5p73-qg2v-383h packbackbooks/lti-1-3-php-library (Packagist) Fixed in 5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31158
- 2026-10-03 Alias added: GHSA-5p73-qg2v-383h
References
More Packback Lti 1.3 Tool Library vulnerabilities
- TI-2022-13200 Use of a Broken or Risky Cryptographic Algorithm in packbackbooks/lti-1-3-php-library CVSS 3.1HIGH 7.5
Sources
- CVE-2022-31158 · CVE Program
- CVE-2022-31158 · NVD
- FIRST EPSS
- GHSA-5p73-qg2v-383h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences