OpenZeppelin Contracts's SignatureChecker may revert on invalid EIP-1271 signers
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-347.
Summary
OpenZeppelin Contracts is a library for smart contract development. Versions 4.1.0 until 4.7.1 are vulnerable to the SignatureChecker reverting. `SignatureChecker.isValidSignatureNow` is not expected to revert. However, an incorrect assumption about Solidity 0.8's `abi.decode` allows some cases to revert, given a target contract that doesn't implement EIP-1271 as expected. The contracts that may be affected are those that use `SignatureChecker` to check the validity of a signature and handle invalid signatures in a way other than reverting. The issue was patched in version 4.7.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenZeppelin | openzeppelin-contracts | 4.1.0 to before 4.7.1 | 4.7.1 | Patch available | CNA |
| — | @openzeppelin/contracts (npm) | 4.1.0 to before 4.7.1 | 4.7.1 | Patch available | GHSA-4g63-c64m-25w9 |
| — | @openzeppelin/contracts-upgradeable (npm) | 4.1.0 to before 4.7.1 | 4.7.1 | Patch available | GHSA-4g63-c64m-25w9 |
- openzeppelin-contracts VendorOpenZeppelin Affected 4.1.0 to before 4.7.1 Fixed in 4.7.1 Patch available CNA
- @openzeppelin/contracts (npm) Vendor— Affected 4.1.0 to before 4.7.1 Fixed in 4.7.1 Patch available GHSA-4g63-c64m-25w9
- @openzeppelin/contracts-upgradeable (npm) Vendor— Affected 4.1.0 to before 4.7.1 Fixed in 4.7.1 Patch available GHSA-4g63-c64m-25w9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openzeppelin:contracts:*:*:*:*:*:node.js:*:* | 4.1.0 to before 4.7.1 | Vulnerable | OpenZeppelin |
- cpe:2.3:a:openzeppelin:contracts:*:*:*:*:*:node.js:*:* Versions 4.1.0 to before 4.7.1 Vulnerable ·OpenZeppelin
Remediation
- Fix · CNA openzeppelin-contracts (OpenZeppelin) Fixed in 4.7.1
- Fix · GHSA-4g63-c64m-25w9 @openzeppelin/contracts (npm) Fixed in 4.7.1 Advisory →
- Fix · GHSA-4g63-c64m-25w9 @openzeppelin/contracts-upgradeable (npm) Fixed in 4.7.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31172
- 2026-10-03 Alias added: GHSA-4g63-c64m-25w9
References
More OpenZeppelin Contracts vulnerabilities
- TI-2022-13196 OpenZeppelin Contracts for Cairo account cannot process transactions on Goerli CVSS 3.1MEDIUM 6.5
- TI-2021-16554 TimelockController vulnerability in OpenZeppelin Contracts CVSS 3.1CRITICAL 10.0
- TI-2021-16553 TimelockController vulnerability in OpenZeppelin Contracts CVSS 3.1CRITICAL 10.0
- TI-2021-18096 UUPSUpgradeable vulnerability in OpenZeppelin Contracts CVSS 3.1CRITICAL 9.8
- TI-2022-13238 GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts CVSS 3.1HIGH 7.5
- TI-2022-13212 OpenZeppelin Contracts's ERC165Checker may revert instead of returning false CVSS 3.1HIGH 7.5
Sources
- CVE-2022-31172 · CVE Program
- CVE-2022-31172 · NVD
- FIRST EPSS
- GHSA-4g63-c64m-25w9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences