Missing brute-force protection in Dell PowerStore
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-307.
Summary
Dell EMC PowerStore, contain(s) an Improper Restriction of Excessive Authentication Attempts Vulnerability in PowerStore Manager GUI. A remote unauthenticated attacker could potentially exploit this vulnerability, leading to password brute-forcing. Account takeover is possible if weak passwords are used by users.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | PowerStore | before v3.0.0.0 | v3.0.0.0 | Patch available | CNA |
- PowerStore VendorDell Affected before v3.0.0.0 Fixed in v3.0.0.0 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:emc_powerstore_500t_firmware:*:*:*:*:*:*:*:* | before 3.0.0.0-1732745 | Vulnerable | Dell |
| cpe:2.3:h:dell:emc_powerstore_500t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:emc_powerstore_1200t_firmware:*:*:*:*:*:*:*:* | before 3.0.0.0-1732745 | Vulnerable | Dell |
| cpe:2.3:h:dell:emc_powerstore_1200t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:emc_powerstore_3200t_firmware:*:*:*:*:*:*:*:* | before 3.0.0.0-1732745 | Vulnerable | Dell |
| cpe:2.3:h:dell:emc_powerstore_3200t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:emc_powerstore_5200t_firmware:*:*:*:*:*:*:*:* | before 3.0.0.0-1732745 | Vulnerable | Dell |
| cpe:2.3:h:dell:emc_powerstore_5200t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:emc_powerstore_9200t_firmware:*:*:*:*:*:*:*:* | before 3.0.0.0-1732745 | Vulnerable | Dell |
| cpe:2.3:h:dell:emc_powerstore_9200t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:emc_powerstore_500t_firmware:*:*:*:*:*:*:*:* Versions before 3.0.0.0-1732745 Vulnerable ·Dell
- cpe:2.3:h:dell:emc_powerstore_500t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:emc_powerstore_1200t_firmware:*:*:*:*:*:*:*:* Versions before 3.0.0.0-1732745 Vulnerable ·Dell
- cpe:2.3:h:dell:emc_powerstore_1200t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:emc_powerstore_3200t_firmware:*:*:*:*:*:*:*:* Versions before 3.0.0.0-1732745 Vulnerable ·Dell
- cpe:2.3:h:dell:emc_powerstore_3200t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:emc_powerstore_5200t_firmware:*:*:*:*:*:*:*:* Versions before 3.0.0.0-1732745 Vulnerable ·Dell
- cpe:2.3:h:dell:emc_powerstore_5200t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:emc_powerstore_9200t_firmware:*:*:*:*:*:*:*:* Versions before 3.0.0.0-1732745 Vulnerable ·Dell
- cpe:2.3:h:dell:emc_powerstore_9200t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Remediation
- Fix · CNA PowerStore (Dell) Fixed in v3.0.0.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell PowerStore v3.0.0.0
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2022-14136 Uncontrolled search path in Dell PowerStorePriority LOW 33
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31234
- 2026-10-03 Alias added: GHSA-mgwj-c8f2-v7qx
References
More Dell Emc Powerstore 1200t Firmware vulnerabilities
- TI-2022-14928 OS command injection in Dell PowerStore CVSS 3.1HIGH 7.8
- TI-2022-06829 OS command injection in Dell PowerStore CVSS 3.1MEDIUM 6.7
Sources
- CVE-2022-31234 · CVE Program
- CVE-2022-31234 · NVD
- FIRST EPSS
- GHSA-mgwj-c8f2-v7qx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences