OS command injection in Dell PowerStore
Priority LOW 34CWE-78Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
Dell PowerStore, versions prior to 3.0.0.0, contains an OS Command Injection vulnerability in PowerStore T environment. A locally authenticated attacker could potentially exploit this vulnerability, leading to the execution of arbitrary OS command on the PowerStore underlying OS. Exploiting may lead to a system take over by an attacker.
Why it matters now
EPSS 0.00351 28th percentileScored 2026-11-07
Fix Fixed PowerStore (Dell): 3.0.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | PowerStore | before 3.0.0.0 | 3.0.0.0 | Patch available | CNA |
- PowerStore VendorDell Affected before 3.0.0.0 Fixed in 3.0.0.0 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:emc_powerstore_500t_firmware:*:*:*:*:*:*:*:* | before 3.0.0.0-1732745 | Vulnerable | Dell |
| cpe:2.3:h:dell:emc_powerstore_500t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:emc_powerstore_1200t_firmware:*:*:*:*:*:*:*:* | before 3.0.0.0-1732745 | Vulnerable | Dell |
| cpe:2.3:h:dell:emc_powerstore_1200t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:emc_powerstore_3200t_firmware:*:*:*:*:*:*:*:* | before 3.0.0.0-1732745 | Vulnerable | Dell |
| cpe:2.3:h:dell:emc_powerstore_3200t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:emc_powerstore_5200t_firmware:*:*:*:*:*:*:*:* | before 3.0.0.0-1732745 | Vulnerable | Dell |
| cpe:2.3:h:dell:emc_powerstore_5200t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:emc_powerstore_9200t_firmware:*:*:*:*:*:*:*:* | before 3.0.0.0-1732745 | Vulnerable | Dell |
| cpe:2.3:h:dell:emc_powerstore_9200t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:emc_powerstore_500t_firmware:*:*:*:*:*:*:*:* Versions before 3.0.0.0-1732745 Vulnerable ·Dell
- cpe:2.3:h:dell:emc_powerstore_500t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:emc_powerstore_1200t_firmware:*:*:*:*:*:*:*:* Versions before 3.0.0.0-1732745 Vulnerable ·Dell
- cpe:2.3:h:dell:emc_powerstore_1200t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:emc_powerstore_3200t_firmware:*:*:*:*:*:*:*:* Versions before 3.0.0.0-1732745 Vulnerable ·Dell
- cpe:2.3:h:dell:emc_powerstore_3200t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:emc_powerstore_5200t_firmware:*:*:*:*:*:*:*:* Versions before 3.0.0.0-1732745 Vulnerable ·Dell
- cpe:2.3:h:dell:emc_powerstore_5200t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:emc_powerstore_9200t_firmware:*:*:*:*:*:*:*:* Versions before 3.0.0.0-1732745 Vulnerable ·Dell
- cpe:2.3:h:dell:emc_powerstore_9200t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Remediation
- Fix · CNA PowerStore (Dell) Fixed in 3.0.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2022-33923
- 2026-10-03 Alias added: GHSA-c4w7-hq99-3rh7
References
More Dell Emc Powerstore 1200t Firmware vulnerabilities
- TI-2022-13272 Missing brute-force protection in Dell PowerStore CVSS 3.1CRITICAL 9.8
- TI-2022-06829 OS command injection in Dell PowerStore CVSS 3.1MEDIUM 6.7
Sources
- CVE-2022-33923 · CVE Program
- CVE-2022-33923 · NVD
- FIRST EPSS
- GHSA-c4w7-hq99-3rh7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences