Read the docs
TI-2022-13554 Aliases CVE-2022-31630GHSA-jw98-jrc9-mrx5

OOB read due to insufficient input validation in imageloadfont()

Priority LOW 34CWE-131Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.

Summary

In PHP versions prior to 7.4.33, 8.0.25 and 8.1.12, when using imageloadfont() function in gd extension, it is possible to supply a specially crafted font file, such as if the loaded font is used with imagechar() function, the read outside allocated buffer will be used. This can lead to crashes or disclosure of confidential information.

Why it matters now

EPSS 0.01317 70th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed PHP (PHP Group): 7.4.33, 8.0.25, 8.1.12Red Hat: 4 advisories

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
PHP GroupPHP7.4.x to before 7.4.33; 8.0.x to before 8.0.25; 8.1.x to before 8.1.127.4.33, 8.0.25, 8.1.12Patch availableCNA
  • PHP VendorPHP Group Affected 7.4.x to before 7.4.33; 8.0.x to before 8.0.25; 8.1.x to before 8.1.12 Fixed in 7.4.33, 8.0.25, 8.1.12 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*7.4.0 to before 7.4.33; 8.0.0 to before 8.0.25; 8.1.0 to before 8.1.12VulnerablePHP
  • cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions 7.4.0 to before 7.4.33; 8.0.0 to before 8.0.25; 8.1.0 to before 8.1.12 Vulnerable ·PHP

Remediation

  • Fix · CNA PHP (PHP Group) Fixed in 7.4.33, 8.0.25, 8.1.12

Red Hat 4 advisories

  • RHSA-2023:2903 Released 2023-05-16 · Red Hat rating Moderate
    php:7.4 security update
    • Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.18-1.module+el8.3.0+6678+b09f589e.noarch::php:7.4, libzip-1.6.1-1.module+el8.3.0+6678+b09f589e.aarch64::php:7.4, libzip-1.6.1-1.module+el8.3.0+6678+b09f589e.ppc64le::php:7.4 +47
  • RHSA-2023:2417 Released 2023-05-09 · Red Hat rating Moderate
    php:8.1 security update
    • Red Hat Enterprise Linux AppStream (v. 9) apcu-panel-5.1.21-1.module+el9.1.0.z+15477+cb86791d.noarch::php:8.1, php-8.1.14-1.module+el9.2.0+17911+b059dfc2.aarch64::php:8.1, php-8.1.14-1.module+el9.2.0+17911+b059dfc2.ppc64le::php:8.1 +47
  • RHSA-2023:0965 Released 2023-02-28 · Red Hat rating Moderate
    php security update
    • Red Hat Enterprise Linux AppStream (v. 9) php-8.0.27-1.el9_1, php-bcmath-8.0.27-1.el9_1, php-cli-8.0.27-1.el9_1 +22
Show 1 more Red Hat advisories
  • RHSA-2023:0848 Released 2023-02-21 · Red Hat rating Moderate
    php:8.0 security update
    • Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.20-1.module+el8.6.0+13671+84712317.noarch::php:8.0, libzip-1.7.3-1.module+el8.6.0+13671+84712317.aarch64::php:8.0, libzip-1.7.3-1.module+el8.6.0+13671+84712317.ppc64le::php:8.0 +47

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2023:0848, RHSA-2023:2903
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2023:0965, RHSA-2023:2417
Not affected: 3 products
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Software Collections

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-31630
  2. 2026-10-03 Alias added: GHSA-jw98-jrc9-mrx5

References

  • TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
  • TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
  • TI-2024-01743 Command injection via array-ish $command parameter of proc_open() CVSS 3.1CRITICAL 9.4
  • TI-2022-13555 PDO::quote() may return unquoted string CVSS 3.1CRITICAL 9.1
  • TI-2024-10408 Reference counting in php_request_shutdown causes Use-After-Free CVSS 4.0CRITICAL 9.2
See all 107 →

Sources