Deserialization of untrusted data in https://github.com/rails/rails
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-502.
Summary
A possible escalation to RCE vulnerability exists when using YAML serialized columns in Active Record < 7.0.3.1, <6.1.6.1, <6.0.5.1 and <5.2.8.1 which could allow an attacker, that can manipulate data in the database (via means like SQL injection), the ability to escalate to an RCE.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | https://github.com/rails/rails | 7.0.3.1, 6.1.6.1, 6.0.5.1, 5.2.8.1 | — | No fix listed | CNA |
| — | activerecord (RubyGems) | 7.0.0 to before 7.0.3.1 | 7.0.3.1 | Patch available | GHSA-3hhc-qp5v-9p2j |
| — | activerecord (RubyGems) | 6.1.0 to before 6.1.6.1 | 6.1.6.1 | Patch available | GHSA-3hhc-qp5v-9p2j |
| — | activerecord (RubyGems) | 6.0.0 to before 6.0.5.1 | 6.0.5.1 | Patch available | GHSA-3hhc-qp5v-9p2j |
| — | activerecord (RubyGems) | before 5.2.8.1 | 5.2.8.1 | Patch available | GHSA-3hhc-qp5v-9p2j |
- https://github.com/rails/rails Vendor— Affected 7.0.3.1, 6.1.6.1, 6.0.5.1, 5.2.8.1 Fixed in — No fix listed CNA
- activerecord (RubyGems) Vendor— Affected 7.0.0 to before 7.0.3.1 Fixed in 7.0.3.1 Patch available GHSA-3hhc-qp5v-9p2j
- activerecord (RubyGems) Vendor— Affected 6.1.0 to before 6.1.6.1 Fixed in 6.1.6.1 Patch available GHSA-3hhc-qp5v-9p2j
- activerecord (RubyGems) Vendor— Affected 6.0.0 to before 6.0.5.1 Fixed in 6.0.5.1 Patch available GHSA-3hhc-qp5v-9p2j
- activerecord (RubyGems) Vendor— Affected before 5.2.8.1 Fixed in 5.2.8.1 Patch available GHSA-3hhc-qp5v-9p2j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:activerecord_project:activerecord:*:*:*:*:*:ruby:*:* | before 5.2.8.1; 6.0.0 to before 6.0.5.1; 6.1.0 to before 6.1.6.1; 7.0.0 to before 7.0.3.1 | Vulnerable | Activerecord Project |
- cpe:2.3:a:activerecord_project:activerecord:*:*:*:*:*:ruby:*:* Versions before 5.2.8.1; 6.0.0 to before 6.0.5.1; 6.1.0 to before 6.1.6.1; 7.0.0 to before 7.0.3.1 Vulnerable ·Activerecord Project
Remediation
- Fix · GHSA-3hhc-qp5v-9p2j activerecord (RubyGems) Fixed in 7.0.3.1 Advisory →
- Fix · GHSA-3hhc-qp5v-9p2j activerecord (RubyGems) Fixed in 6.1.6.1 Advisory →
- Fix · GHSA-3hhc-qp5v-9p2j activerecord (RubyGems) Fixed in 6.0.5.1 Advisory →
- Fix · GHSA-3hhc-qp5v-9p2j activerecord (RubyGems) Fixed in 5.2.8.1 Advisory →
Red Hat 3 advisories
- RHSA-2023:2097 Released 2023-05-03 · Red Hat rating ImportantSatellite 6.13 Release
- Red Hat Satellite 6.13 for RHEL 8 ansible-collection-redhat-satellite-3.9.0-2.el8sat, ansible-collection-redhat-satellite_operations-1.3.0-2.el8sat, ansible-lint-5.0.8-4.el8pc +47
- RHSA-2023:1151 Released 2023-03-07 · Red Hat rating CriticalSatellite 6.11.5 Async Security Update
- Red Hat Satellite 6.11 for RHEL 7 candlepin-4.1.19-1.el7sat, candlepin-selinux-4.1.19-1.el7sat, foreman-3.1.1.26-1.el7sat +42
- Red Hat Satellite 6.11 for RHEL 8 candlepin-4.1.19-1.el8sat, candlepin-selinux-4.1.19-1.el8sat, foreman-3.1.1.26-1.el8sat +42
- RHSA-2023:0261 Released 2023-01-18 · Red Hat rating CriticalSatellite 6.12.1 Async Security Update
- Red Hat Satellite 6.12 for RHEL 8 candlepin-4.1.18-1.el8sat, candlepin-selinux-4.1.18-1.el8sat, foreman-3.3.0.18-1.el8sat +41
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Satellite 6.11 for RHEL 7 | Fixed | RHSA-2023:1151 |
| Red Hat Satellite 6.11 for RHEL 8 | Fixed | RHSA-2023:1151 |
| Red Hat Satellite 6.12 for RHEL 8 | Fixed | RHSA-2023:0261 |
| Red Hat Satellite 6.13 for RHEL 8 | Fixed | RHSA-2023:2097 |
Not affected: 4 products
- Red Hat Satellite 6.11 for RHEL 7
- Red Hat Satellite 6.11 for RHEL 8
- Red Hat Satellite 6.12 for RHEL 8
- Red Hat Satellite 6.13 for RHEL 8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-32224
- 2026-10-03 Alias added: GHSA-3hhc-qp5v-9p2j
References
Other 5
- https://github.com/rails/rails/commit/611990f1a6c137c2d56b1ba06b27e5d2434dcd6a
- https://discuss.rubyonrails.org/t/cve-2022-32224-possible-rce-escalation-bug-with-serialized-columns-in-active-record/81017
- https://github.com/rails/rails/commits/main/activerecord
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activerecord/CVE-2022-32224.yml
- https://lists.debian.org/debian-lts-announce/2026/05/msg00022.html
More Activerecord Project Activerecord vulnerabilities
- TI-2022-21907 Uncontrolled resource consumption in https://github.com/rails/rails CVSS 3.1HIGH 7.5
- TI-2023-08966 SQL injection in https://github.com/rails/rails CVSS 3.1HIGH 8.8
Sources
- CVE-2022-32224 · CVE Program
- CVE-2022-32224 · NVD
- FIRST EPSS
- GHSA-3hhc-qp5v-9p2j · GitHub Advisory Database · CC BY 4.0
- CVE-2022-32224 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences