Read the docs
TI-2022-21907 Aliases CVE-2022-44566GHSA-579w-22j4-4749

Uncontrolled resource consumption in https://github.com/rails/rails

Priority HIGH 72CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.

Summary

A denial of service vulnerability present in ActiveRecord's PostgreSQL adapter <7.0.4.1 and <6.1.7.1. When a value outside the range for a 64bit signed integer is provided to the PostgreSQL connection adapter, it will treat the target column type as numeric. Comparing integer values against numeric values can result in a slow sequential scan resulting in potential Denial of Service.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01265 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed activerecord (RubyGems): 6.1.7.1, 7.0.4.1Red Hat: 1 advisory

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—https://github.com/rails/rails7.0.4.1, 6.1.7.1—No fix listedCNA
—activerecord (RubyGems)before 6.1.7.16.1.7.1Patch availableGHSA-579w-22j4-4749
—activerecord (RubyGems)7.0.0 to before 7.0.4.17.0.4.1Patch availableGHSA-579w-22j4-4749
  • https://github.com/rails/rails Vendor— Affected 7.0.4.1, 6.1.7.1 Fixed in — No fix listed CNA
  • activerecord (RubyGems) Vendor— Affected before 6.1.7.1 Fixed in 6.1.7.1 Patch available GHSA-579w-22j4-4749
  • activerecord (RubyGems) Vendor— Affected 7.0.0 to before 7.0.4.1 Fixed in 7.0.4.1 Patch available GHSA-579w-22j4-4749

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:activerecord_project:activerecord:*:*:*:*:*:ruby:*:*before 6.1.7.1; 7.0.0 to before 7.0.4.1VulnerableActiverecord Project
  • cpe:2.3:a:activerecord_project:activerecord:*:*:*:*:*:ruby:*:* Versions before 6.1.7.1; 7.0.0 to before 7.0.4.1 Vulnerable ·Activerecord Project

Remediation

  • Fix · GHSA-579w-22j4-4749 activerecord (RubyGems) Fixed in 6.1.7.1 Advisory →
  • Fix · GHSA-579w-22j4-4749 activerecord (RubyGems) Fixed in 7.0.4.1 Advisory →

Red Hat 1 advisory

  • RHSA-2023:6818 Released 2023-11-08 · Red Hat rating Important
    Satellite 6.14 security and bug fix update
    • Red Hat Satellite 6.14 for RHEL 8 foreman-3.7.0.9-1.el8sat, foreman-cli-3.7.0.9-1.el8sat, foreman-debug-3.7.0.9-1.el8sat +33

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Satellite 6.14 for RHEL 8Fixed RHSA-2023:6818
Not affected: 1 product
  • Red Hat Satellite 6.14 for RHEL 8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-44566
  2. 2026-10-03 Alias added: GHSA-579w-22j4-4749

References

  • TI-2022-13933 Deserialization of untrusted data in https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
  • TI-2023-08966 SQL injection in https://github.com/rails/rails CVSS 3.1HIGH 8.8

Sources