Read the docs
TI-2022-14801 Aliases CVE-2022-33683GHSA-j3qw-g67q-7m64

Disabled Certificate Validation makes Broker, Proxy Admin Clients vulnerable to MITM attack

Priority LOW 28CWE-295Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Spoofing
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-295.

Summary

Apache Pulsar Brokers and Proxies create an internal Pulsar Admin Client that does not verify peer TLS certificates, even when tlsAllowInsecureConnection is disabled via configuration. The Pulsar Admin Client's intra-cluster and geo-replication HTTPS connections are vulnerable to man in the middle attacks, which could leak authentication data, configuration data, and any other data sent by these clients. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack. This issue affects Apache Pulsar Broker and Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0; 2.6.4 and earlier.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00682 52nd percentileScored 2026-11-07
Fix Fixed org.apache.pulsar:pulsar-broker (Maven): 2.7.5, 2.8.4, 2.9.3 +1org.apache.pulsar:pulsar-proxy (Maven): 2.7.5, 2.8.4, 2.9.3 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Pulsar2.10.0; 2.7 – 2.7.4; 2.8 – 2.8.3; 2.9 – 2.9.2; 2.6 and earlier – 2.6.4—No fix listedCNA
—org.apache.pulsar:pulsar-broker (Maven)before 2.7.52.7.5Patch availableGHSA-j3qw-g67q-7m64
—org.apache.pulsar:pulsar-proxy (Maven)before 2.7.52.7.5Patch availableGHSA-j3qw-g67q-7m64
—org.apache.pulsar:pulsar-broker (Maven)2.8.0 to before 2.8.42.8.4Patch availableGHSA-j3qw-g67q-7m64
—org.apache.pulsar:pulsar-proxy (Maven)2.8.0 to before 2.8.42.8.4Patch availableGHSA-j3qw-g67q-7m64
—org.apache.pulsar:pulsar-broker (Maven)2.9.0 to before 2.9.32.9.3Patch availableGHSA-j3qw-g67q-7m64
—org.apache.pulsar:pulsar-proxy (Maven)2.9.0 to before 2.9.32.9.3Patch availableGHSA-j3qw-g67q-7m64
—org.apache.pulsar:pulsar-broker (Maven)2.10.0 to before 2.10.12.10.1Patch availableGHSA-j3qw-g67q-7m64
—org.apache.pulsar:pulsar-proxy (Maven)2.10.0 to before 2.10.12.10.1Patch availableGHSA-j3qw-g67q-7m64
  • Apache Pulsar VendorApache Affected 2.10.0; 2.7 – 2.7.4; 2.8 – 2.8.3; 2.9 – 2.9.2; 2.6 and earlier – 2.6.4 Fixed in — No fix listed CNA
  • org.apache.pulsar:pulsar-broker (Maven) Vendor— Affected before 2.7.5 Fixed in 2.7.5 Patch available GHSA-j3qw-g67q-7m64
  • org.apache.pulsar:pulsar-proxy (Maven) Vendor— Affected before 2.7.5 Fixed in 2.7.5 Patch available GHSA-j3qw-g67q-7m64
  • org.apache.pulsar:pulsar-broker (Maven) Vendor— Affected 2.8.0 to before 2.8.4 Fixed in 2.8.4 Patch available GHSA-j3qw-g67q-7m64
  • org.apache.pulsar:pulsar-proxy (Maven) Vendor— Affected 2.8.0 to before 2.8.4 Fixed in 2.8.4 Patch available GHSA-j3qw-g67q-7m64
  • org.apache.pulsar:pulsar-broker (Maven) Vendor— Affected 2.9.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-j3qw-g67q-7m64
  • org.apache.pulsar:pulsar-proxy (Maven) Vendor— Affected 2.9.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-j3qw-g67q-7m64
  • org.apache.pulsar:pulsar-broker (Maven) Vendor— Affected 2.10.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-j3qw-g67q-7m64
  • org.apache.pulsar:pulsar-proxy (Maven) Vendor— Affected 2.10.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-j3qw-g67q-7m64

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:*before 2.7.5; 2.8.0 to before 2.8.4; 2.9.0 to before 2.9.3VulnerableApache
cpe:2.3:a:apache:pulsar:2.10.0:-:*:*:*:*:*:*2.10.0VulnerableApache
  • cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:* Versions before 2.7.5; 2.8.0 to before 2.8.4; 2.9.0 to before 2.9.3 Vulnerable ·Apache
  • cpe:2.3:a:apache:pulsar:2.10.0:-:*:*:*:*:*:* Versions 2.10.0 Vulnerable ·Apache

Remediation

  • Fix · GHSA-j3qw-g67q-7m64 org.apache.pulsar:pulsar-broker (Maven) Fixed in 2.7.5 Advisory →
  • Fix · GHSA-j3qw-g67q-7m64 org.apache.pulsar:pulsar-proxy (Maven) Fixed in 2.7.5 Advisory →
  • Fix · GHSA-j3qw-g67q-7m64 org.apache.pulsar:pulsar-broker (Maven) Fixed in 2.8.4 Advisory →
  • Fix · GHSA-j3qw-g67q-7m64 org.apache.pulsar:pulsar-proxy (Maven) Fixed in 2.8.4 Advisory →
  • Fix · GHSA-j3qw-g67q-7m64 org.apache.pulsar:pulsar-broker (Maven) Fixed in 2.9.3 Advisory →
  • Fix · GHSA-j3qw-g67q-7m64 org.apache.pulsar:pulsar-proxy (Maven) Fixed in 2.9.3 Advisory →
  • Fix · GHSA-j3qw-g67q-7m64 org.apache.pulsar:pulsar-broker (Maven) Fixed in 2.10.1 Advisory →
  • Fix · GHSA-j3qw-g67q-7m64 org.apache.pulsar:pulsar-proxy (Maven) Fixed in 2.10.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-33683
  2. 2026-10-03 Alias added: GHSA-j3qw-g67q-7m64

References

  • TI-2024-18155 Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification CVSS 3.1CRITICAL 9.9
  • TI-2021-05150 Authentication with JWT allows use of “none”-algorithm CVSS 3.1CRITICAL 9.8
  • TI-2024-17990 Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution CVSS 3.1CRITICAL 9.9
  • TI-2023-14272 Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy CVSS 3.1CRITICAL 9.6
  • TI-2022-15232 Apache Pulsar: Improper Authentication for Pulsar Proxy Statistics Endpoint CVSS 3.1HIGH 8.2
  • TI-2024-18500 Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying CVSS 3.1HIGH 8.8
See all 19 →

Sources