Improper certificate validation in Apache Pulsar
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
The Apache Pulsar C++ Client does not verify peer TLS certificates when making HTTPS calls for the OAuth2.0 Client Credential Flow, even when tlsAllowInsecureConnection is disabled via configuration. This vulnerability allows an attacker to perform a man in the middle attack and intercept and/or modify the GET request that is sent to the ClientCredentialFlow 'issuer url'. The intercepted credentials can be used to acquire authentication data from the OAuth2.0 server to then authenticate with an Apache Pulsar cluster. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack. The Apache Pulsar Python Client wraps the C++ client, so it is also vulnerable in the same way. This issue affects Apache Pulsar C++ Client and Python Client versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0 to 2.10.1; 2.6.4 and earlier. Any users running affected versions of the C++ Client or the Python Client should rotate vulnerable OAuth2.0 credentials, including client_id and client_secret. 2.7 C++ and Python Client users should upgrade to 2.7.5 and rotate vulnerable OAuth2.0 credentials. 2.8 C++ and Python Client users should upgrade to 2.8.4 and rotate vulnerable OAuth2.0 credentials. 2.9 C++ and Python Client users should upgrade to 2.9.3 and rotate vulnerable OAuth2.0 credentials. 2.10 C++ and Python Client users should upgrade to 2.10.2 and rotate vulnerable OAuth2.0 credentials. 3.0 C++ users are unaffected and 3.0 Python Client users will be unaffected when it is released. Any users running the C++ and Python Client for 2.6 or less should upgrade to one of the above patched versions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Pulsar | 2.7 – 2.7.4; 2.8 – 2.8.3; 2.9 – 2.9.2; 2.10 – 2.10.1; 2.6 and earlier – 2.6.4 | 3.0.0 | Patch available | CNA |
| — | pulsar-client (PyPI) | before 2.7.5 | 2.7.5 | Patch available | GHSA-5r3h-c3r7-9w4h |
| — | pulsar-client (PyPI) | 2.8.0 to before 2.8.4 | 2.8.4 | Patch available | GHSA-5r3h-c3r7-9w4h |
| — | pulsar-client (PyPI) | 2.9.0 to before 2.9.3 | 2.9.3 | Patch available | GHSA-5r3h-c3r7-9w4h |
| — | pulsar-client (PyPI) | 2.10.0 to before 2.10.2 | 2.10.2 | Patch available | GHSA-5r3h-c3r7-9w4h |
- Apache Pulsar VendorApache Affected 2.7 – 2.7.4; 2.8 – 2.8.3; 2.9 – 2.9.2; 2.10 – 2.10.1; 2.6 and earlier – 2.6.4 Fixed in 3.0.0 Patch available CNA
- pulsar-client (PyPI) Vendor— Affected before 2.7.5 Fixed in 2.7.5 Patch available GHSA-5r3h-c3r7-9w4h
- pulsar-client (PyPI) Vendor— Affected 2.8.0 to before 2.8.4 Fixed in 2.8.4 Patch available GHSA-5r3h-c3r7-9w4h
- pulsar-client (PyPI) Vendor— Affected 2.9.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-5r3h-c3r7-9w4h
- pulsar-client (PyPI) Vendor— Affected 2.10.0 to before 2.10.2 Fixed in 2.10.2 Patch available GHSA-5r3h-c3r7-9w4h
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:* | up to 2.6.4; 2.7.0 to before 2.7.5; 2.8.0 to before 2.8.4; 2.9.0 to before 2.9.3; 2.10.0 to before 2.10.2 | Vulnerable | Apache |
- cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:* Versions up to 2.6.4; 2.7.0 to before 2.7.5; 2.8.0 to before 2.8.4; 2.9.0 to before 2.9.3; 2.10.0 to before 2.10.2 Vulnerable ·Apache
Remediation
- Fix · CNA Apache Pulsar (Apache Software Foundation) Fixed in 3.0.0
- Fix · GHSA-5r3h-c3r7-9w4h pulsar-client (PyPI) Fixed in 2.7.5 Advisory →
- Fix · GHSA-5r3h-c3r7-9w4h pulsar-client (PyPI) Fixed in 2.8.4 Advisory →
- Fix · GHSA-5r3h-c3r7-9w4h pulsar-client (PyPI) Fixed in 2.9.3 Advisory →
- Fix · GHSA-5r3h-c3r7-9w4h pulsar-client (PyPI) Fixed in 2.10.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-33684
- 2026-10-03 Alias added: GHSA-5r3h-c3r7-9w4h
References
More Apache Pulsar vulnerabilities
- TI-2024-18155 Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification CVSS 3.1CRITICAL 9.9
- TI-2021-05150 Authentication with JWT allows use of “none”-algorithm CVSS 3.1CRITICAL 9.8
- TI-2024-17990 Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution CVSS 3.1CRITICAL 9.9
- TI-2023-14272 Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy CVSS 3.1CRITICAL 9.6
- TI-2022-15232 Apache Pulsar: Improper Authentication for Pulsar Proxy Statistics Endpoint CVSS 3.1HIGH 8.2
- TI-2024-18500 Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying CVSS 3.1HIGH 8.8
Sources
- CVE-2022-33684 · CVE Program
- CVE-2022-33684 · NVD
- FIRST EPSS
- GHSA-5r3h-c3r7-9w4h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences