Improper input validation in Samsung Galaxy Store
Priority LOW 33CWE-20Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
Improper input validation vulnerability in ApexPackageInstaller in Galaxy Store prior to version 4.5.41.8 allows local attackers to launch activities as Galaxy Store privilege.
Why it matters now
EPSS 0.00214 11th percentileScored 2026-11-07
Fix Fixed Galaxy Store (Samsung Mobile): 4.5.41.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Galaxy Store (Samsung Mobile) Fixed in 4.5.41.8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Samsung Mobile Galaxy Store 4.5.41.8
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2022-14828 Improper input validation in Samsung Galaxy StorePriority LOW 33
- TI-2022-14826 Improper input validation in Samsung Galaxy StorePriority LOW 33
Timeline
- 2026-10-02 Threatist record created from CVE-2022-33709
- 2026-10-03 Alias added: GHSA-gqv7-wg8q-m48q
References
More Samsung Galaxy Store vulnerabilities
- TI-2023-07917 Improper input validation in Samsung Galaxy Store CVSS 3.1CRITICAL 9.6
- TI-2023-07916 Improper input validation in Samsung Galaxy Store CVSS 3.1HIGH 8.8
- TI-2023-22730 Improper URL validation from MCSLaunch deeplink in Galaxy Store prior to version 4.5.64.4… CVSS 3.1CRITICAL 9.8
- TI-2023-07835 Improper input validation in Samsung Galaxy Store CVSS 3.1MEDIUM 6.2
- TI-2023-07834 Improper authorization in Samsung Galaxy Store CVSS 3.1HIGH 7.8
- TI-2023-07915 Improper input validation in Samsung Galaxy Store CVSS 3.1HIGH 8.8
Sources
- CVE-2022-33709 · CVE Program
- CVE-2022-33709 · NVD
- FIRST EPSS
- GHSA-gqv7-wg8q-m48q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences