Observable discrepancy in Jenkins
Priority LOW 36CWE-203Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 3 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-203.
Summary
In Jenkins 2.355 and earlier, LTS 2.332.3 and earlier, an observable timing discrepancy on the login form allows distinguishing between login attempts with an invalid username, and login attempts with a valid username and wrong password, when using the Jenkins user database security realm.
Why it matters now
EPSS 0.01628 76th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.356, 2.332.4Red Hat: 3 advisoriesRed Hat: 3 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins | up to 2.355; up to LTS 2.332.3 | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.334 to before 2.356 | 2.356 | Patch available | GHSA-9grj-j43m-mjqr |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.332.4 | 2.332.4 | Patch available | GHSA-9grj-j43m-mjqr |
- Jenkins VendorJenkins Affected up to 2.355; up to LTS 2.332.3 Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.334 to before 2.356 Fixed in 2.356 Patch available GHSA-9grj-j43m-mjqr
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.332.4 Fixed in 2.332.4 Patch available GHSA-9grj-j43m-mjqr
Remediation
- Fix · GHSA-9grj-j43m-mjqr org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.356 Advisory →
- Fix · GHSA-9grj-j43m-mjqr org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.332.4 Advisory →
Red Hat 3 advisories
- RHSA-2023:0777 Released 2023-02-23 · Red Hat rating CriticalOpenShift Container Platform 4.9.56 security update
- Red Hat OpenShift Container Platform 4.9 jenkins-2-plugins-4.9.1675668922-1.el8, jenkins-2.361.1.1675668150-1.el8
- RHSA-2023:0697 Released 2023-02-15 · Red Hat rating ImportantOpenShift Container Platform 4.10.52 security update
- Red Hat OpenShift Container Platform 4.10 jenkins-2-plugins-4.10.1675407676-1.el8, jenkins-2.361.1.1675406172-1.el8
- RHSA-2023:0017 Released 2023-01-12 · Red Hat rating ImportantOpenShift Container Platform 4.8.56 packages and security update
- Red Hat OpenShift Container Platform 4.8 jenkins-2-plugins-4.8.1672842762-1.el8, jenkins-2.361.1.1672840472-1.el8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 4.10 | Fixed | RHSA-2023:0697 |
| Red Hat OpenShift Container Platform 4.8 | Fixed | RHSA-2023:0017 |
| Red Hat OpenShift Container Platform 4.9 | Fixed | RHSA-2023:0777 |
Not affected: 3 products
- Red Hat OpenShift Container Platform 4.10
- Red Hat OpenShift Container Platform 4.8
- Red Hat OpenShift Container Platform 4.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-34174
- 2026-10-03 Alias added: GHSA-9grj-j43m-mjqr
References
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2022-34174 · CVE Program
- CVE-2022-34174 · NVD
- FIRST EPSS
- GHSA-9grj-j43m-mjqr · GitHub Advisory Database · CC BY 4.0
- CVE-2022-34174 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences