Read the docs
TI-2022-15106 Aliases CVE-2022-34191GHSA-pv38-mqpp-v72h

Cross-site scripting in Jenkins NS-ND Integration Performance Publisher Plugin

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.77 and earlier does not escape the name of NetStorm Test parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Why it matters now

EPSS 0.00656 51st percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:cavisson-ns-nd-integration (Maven): 4.8.0.129

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins NS-ND Integration Performance Publisher Pluginup to 4.8.0.77—No fix listedCNA
—io.jenkins.plugins:cavisson-ns-nd-integration (Maven)before 4.8.0.1294.8.0.129Patch availableGHSA-pv38-mqpp-v72h
  • Jenkins NS-ND Integration Performance Publisher Plugin VendorJenkins Affected up to 4.8.0.77 Fixed in — No fix listed CNA
  • io.jenkins.plugins:cavisson-ns-nd-integration (Maven) Vendor— Affected before 4.8.0.129 Fixed in 4.8.0.129 Patch available GHSA-pv38-mqpp-v72h

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:ns-nd_integration_performance_publisher:*:*:*:*:*:jenkins:*:*up to 4.8.0.77VulnerableJenkins
  • cpe:2.3:a:jenkins:ns-nd_integration_performance_publisher:*:*:*:*:*:jenkins:*:* Versions up to 4.8.0.77 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-pv38-mqpp-v72h io.jenkins.plugins:cavisson-ns-nd-integration (Maven) Fixed in 4.8.0.129 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-34191
  2. 2026-10-03 Alias added: GHSA-pv38-mqpp-v72h
  3. 2026-10-21 EPSS moved to the 50th–90th percentile

References

  • TI-2022-19738 Missing authorization in Jenkins NS-ND Integration Performance Publisher Plugin CVSS 3.1HIGH 8.8
  • TI-2022-19737 Cross-site request forgery in Jenkins NS-ND Integration Performance Publisher Plugin CVSS 3.1HIGH 8.8
  • TI-2023-16188 Insufficiently protected credentials in Jenkins NS-ND Integration Performance Publisher… CVSS 3.1HIGH 7.5
  • TI-2022-22357 Improper certificate validation in Jenkins NS-ND Integration Performance Publisher Plugin CVSS 3.1HIGH 7.5
  • TI-2022-18199 Improper certificate validation in Jenkins NS-ND Integration Performance Publisher Plugin CVSS 3.1HIGH 7.5
  • TI-2022-22358 Insufficiently protected credentials in Jenkins NS-ND Integration Performance Publisher… CVSS 3.1MEDIUM 6.5
See all 7 →

Sources