Cross-site request forgery in Jenkins NS-ND Integration Performance Publisher Plugin
Priority MEDIUM 41CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A cross-site request forgery (CSRF) vulnerability in Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.129 and earlier allows attackers to connect to an attacker-specified webserver using attacker-specified credentials.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00543 45th percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:cavisson-ns-nd-integration (Maven): 4.8.0.130
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins NS-ND Integration Performance Publisher Plugin | up to 4.8.0.129 | — | No fix listed | CNA |
| — | io.jenkins.plugins:cavisson-ns-nd-integration (Maven) | before 4.8.0.130 | 4.8.0.130 | Patch available | GHSA-jjch-7g85-4m72 |
- Jenkins NS-ND Integration Performance Publisher Plugin VendorJenkins Affected up to 4.8.0.129 Fixed in — No fix listed CNA
- io.jenkins.plugins:cavisson-ns-nd-integration (Maven) Vendor— Affected before 4.8.0.130 Fixed in 4.8.0.130 Patch available GHSA-jjch-7g85-4m72
Remediation
- Fix · GHSA-jjch-7g85-4m72 io.jenkins.plugins:cavisson-ns-nd-integration (Maven) Fixed in 4.8.0.130 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-41227
- 2026-10-03 Alias added: GHSA-jjch-7g85-4m72
References
More Jenkins Ns-nd Integration Performance Publisher vulnerabilities
- TI-2022-19738 Missing authorization in Jenkins NS-ND Integration Performance Publisher Plugin CVSS 3.1HIGH 8.8
- TI-2023-16188 Insufficiently protected credentials in Jenkins NS-ND Integration Performance Publisher… CVSS 3.1HIGH 7.5
- TI-2022-22357 Improper certificate validation in Jenkins NS-ND Integration Performance Publisher Plugin CVSS 3.1HIGH 7.5
- TI-2022-18199 Improper certificate validation in Jenkins NS-ND Integration Performance Publisher Plugin CVSS 3.1HIGH 7.5
- TI-2022-22358 Insufficiently protected credentials in Jenkins NS-ND Integration Performance Publisher… CVSS 3.1MEDIUM 6.5
- TI-2022-19739 Cross-site scripting in Jenkins NS-ND Integration Performance Publisher Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-41227 · CVE Program
- CVE-2022-41227 · NVD
- FIRST EPSS
- GHSA-jjch-7g85-4m72 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences