Read the docs
TI-2022-15167 Aliases CVE-2022-34255GHSA-x95x-f4g9-mm85

Adobe Commerce Improper Access Control Privilege escalation

Priority MEDIUM 45CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284.

Summary

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in Privilege escalation. An attacker with a low privilege account could leverage this vulnerability to perform an account takeover for a victim. Exploitation of this issue does not require user interaction.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0236 83rd percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.3.7-p4, 2.4.5, 2.4.3-p3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AdobeMagento Commerceup to 2.4.4; up to 2.3.7-p3; up to 2.4.3-p2; up to None—No fix listedCNA
—magento/community-edition (Packagist)2.3.0 to before 2.3.7-p42.3.7-p4Patch availableGHSA-x95x-f4g9-mm85
—magento/community-edition (Packagist)2.4.4 to before 2.4.52.4.5Patch availableGHSA-x95x-f4g9-mm85
—magento/community-edition (Packagist)2.4.0 to before 2.4.3-p32.4.3-p3Patch availableGHSA-x95x-f4g9-mm85
  • Magento Commerce VendorAdobe Affected up to 2.4.4; up to 2.3.7-p3; up to 2.4.3-p2; up to None Fixed in — No fix listed CNA
  • magento/community-edition (Packagist) Vendor— Affected 2.3.0 to before 2.3.7-p4 Fixed in 2.3.7-p4 Patch available GHSA-x95x-f4g9-mm85
  • magento/community-edition (Packagist) Vendor— Affected 2.4.4 to before 2.4.5 Fixed in 2.4.5 Patch available GHSA-x95x-f4g9-mm85
  • magento/community-edition (Packagist) Vendor— Affected 2.4.0 to before 2.4.3-p3 Fixed in 2.4.3-p3 Patch available GHSA-x95x-f4g9-mm85

CPE configurations NVD · 18

CPEVersionsRoleVendor
cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:*2.3.0 to before 2.3.7; 2.4.0 to before 2.4.3VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.3.7:-:*:*:*:*:*:*2.3.7VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.3.7:p1:*:*:*:*:*:*2.3.7 p1VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.3.7:p2:*:*:*:*:*:*2.3.7 p2VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.3.7:p3:*:*:*:*:*:*2.3.7 p3VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.3:-:*:*:*:*:*:*2.4.3VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.3:p1:*:*:*:*:*:*2.4.3 p1VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.3:p2:*:*:*:*:*:*2.4.3 p2VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:*2.4.4VulnerableAdobe
cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:*2.3.0 to before 2.3.7; 2.4.0 to before 2.4.3VulnerableMagento
  • cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* Versions 2.3.0 to before 2.3.7; 2.4.0 to before 2.4.3 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.3.7:-:*:*:*:*:*:* Versions 2.3.7 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.3.7:p1:*:*:*:*:*:* Versions 2.3.7 p1 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.3.7:p2:*:*:*:*:*:* Versions 2.3.7 p2 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.3.7:p3:*:*:*:*:*:* Versions 2.3.7 p3 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.3:-:*:*:*:*:*:* Versions 2.4.3 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.3:p1:*:*:*:*:*:* Versions 2.4.3 p1 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.3:p2:*:*:*:*:*:* Versions 2.4.3 p2 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·Adobe
  • cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.3.0 to before 2.3.7; 2.4.0 to before 2.4.3 Vulnerable ·Magento
Show 8 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:magento:magento:2.3.7:-:*:*:commerce:*:*:*2.3.7VulnerableMagento
cpe:2.3:a:magento:magento:2.3.7:p1:*:*:commerce:*:*:*2.3.7 p1VulnerableMagento
cpe:2.3:a:magento:magento:2.3.7:p2:*:*:commerce:*:*:*2.3.7 p2VulnerableMagento
cpe:2.3:a:magento:magento:2.3.7:p3:*:*:commerce:*:*:*2.3.7 p3VulnerableMagento
cpe:2.3:a:magento:magento:2.4.3:-:*:*:commerce:*:*:*2.4.3VulnerableMagento
cpe:2.3:a:magento:magento:2.4.3:p1:*:*:commerce:*:*:*2.4.3 p1VulnerableMagento
cpe:2.3:a:magento:magento:2.4.3:p2:*:*:commerce:*:*:*2.4.3 p2VulnerableMagento
cpe:2.3:a:magento:magento:2.4.4:-:*:*:commerce:*:*:*2.4.4VulnerableMagento
  • cpe:2.3:a:magento:magento:2.3.7:-:*:*:commerce:*:*:* Versions 2.3.7 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.3.7:p1:*:*:commerce:*:*:* Versions 2.3.7 p1 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.3.7:p2:*:*:commerce:*:*:* Versions 2.3.7 p2 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.3.7:p3:*:*:commerce:*:*:* Versions 2.3.7 p3 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.4.3:-:*:*:commerce:*:*:* Versions 2.4.3 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.4.3:p1:*:*:commerce:*:*:* Versions 2.4.3 p1 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.4.3:p2:*:*:commerce:*:*:* Versions 2.4.3 p2 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.4.4:-:*:*:commerce:*:*:* Versions 2.4.4 Vulnerable ·Magento

Remediation

  • Fix · GHSA-x95x-f4g9-mm85 magento/community-edition (Packagist) Fixed in 2.3.7-p4 Advisory →
  • Fix · GHSA-x95x-f4g9-mm85 magento/community-edition (Packagist) Fixed in 2.4.5 Advisory →
  • Fix · GHSA-x95x-f4g9-mm85 magento/community-edition (Packagist) Fixed in 2.4.3-p3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-34255
  2. 2026-10-03 Alias added: GHSA-x95x-f4g9-mm85

References

  • TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-08035 Adobe Commerce checkout improper input validation leads to remote code execution KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-35762 Unrestricted file upload in Adobe Commerce allows code execution KEVCVSS 3.1CRITICAL 9.3
  • TI-2026-50010 Adobe Commerce | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 9.1
  • TI-2025-34067 Adobe Commerce | Improper Input Validation (CWE-20) KEVCVSS 3.1CRITICAL 9.1
See all 213 →

Sources