Cross-site scripting in Jenkins Plot Plugin
Priority HIGH 65CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Plot Plugin 2.1.10 and earlier does not escape plot descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Why it matters now
EPSS 0.81756 99th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:plot (Maven): 2.1.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Plot Plugin | up to 2.1.10 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:plot (Maven) | before 2.1.11 | 2.1.11 | Patch available | GHSA-hpf7-mmqw-g6vq |
- Jenkins Plot Plugin VendorJenkins Affected up to 2.1.10 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:plot (Maven) Vendor— Affected before 2.1.11 Fixed in 2.1.11 Patch available GHSA-hpf7-mmqw-g6vq
Remediation
- Fix · GHSA-hpf7-mmqw-g6vq org.jenkins-ci.plugins:plot (Maven) Fixed in 2.1.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-34783
- 2026-10-03 Alias added: GHSA-hpf7-mmqw-g6vq
References
More Jenkins Plot vulnerabilities
- TI-2022-23072 Jenkins Plot Plugin 2.1.11 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-34783 · CVE Program
- CVE-2022-34783 · NVD
- FIRST EPSS
- GHSA-hpf7-mmqw-g6vq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences