Read the docs
TI-2022-23072 Aliases CVE-2022-46682GHSA-wgpp-g6v9-7hxp

Jenkins Plot Plugin 2.1.11 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.

Priority MEDIUM 51CWE-611Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

Jenkins Plot Plugin 2.1.11 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0101 63rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:plot (Maven): 2.1.12

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Plot Pluginup to 2.1.11—No fix listedCNA
—org.jenkins-ci.plugins:plot (Maven)before 2.1.122.1.12Patch availableGHSA-wgpp-g6v9-7hxp
  • Jenkins Plot Plugin VendorJenkins Affected up to 2.1.11 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:plot (Maven) Vendor— Affected before 2.1.12 Fixed in 2.1.12 Patch available GHSA-wgpp-g6v9-7hxp

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:plot:*:*:*:*:*:jenkins:*:*before 2.1.12VulnerableJenkins
  • cpe:2.3:a:jenkins:plot:*:*:*:*:*:jenkins:*:* Versions before 2.1.12 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-wgpp-g6v9-7hxp org.jenkins-ci.plugins:plot (Maven) Fixed in 2.1.12 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-46682
  2. 2026-10-03 Alias added: GHSA-wgpp-g6v9-7hxp

References

  • TI-2022-15590 Cross-site scripting in Jenkins Plot Plugin CVSS 3.1MEDIUM 5.4

Sources