Unauthenticated clients may cause OutOfMemoryError on Apache Kafka Brokers
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-789.
Summary
A security vulnerability has been identified in Apache Kafka. It affects all releases since 2.8.0. The vulnerability allows malicious unauthenticated clients to allocate large amounts of memory on brokers. This can lead to brokers hitting OutOfMemoryException and causing denial of service. Example scenarios: - Kafka cluster without authentication: Any clients able to establish a network connection to a broker can trigger the issue. - Kafka cluster with SASL authentication: Any clients able to establish a network connection to a broker, without the need for valid SASL credentials, can trigger the issue. - Kafka cluster with TLS authentication: Only clients able to successfully authenticate via TLS can trigger the issue. We advise the users to upgrade the Kafka installations to one of the 3.2.3, 3.1.2, 3.0.2, 2.8.2 versions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Kafka | Apache Kafka 2.8.0 2.8.0 ; Apache Kafka 2.8.1 2.8.1; Apache Kafka 3.0.0 3.0.0; Apache Kafka 3.0.1 3.0.1; Apache Kafka 3.1.0 3.1.0; Apache Kafka 3.1.1 3.1.1; Apache Kafka 3.2.0 3.2.0; Apache Kafka 3.2.1 3.2.1 | — | No fix listed | CNA |
| — | org.apache.kafka:kafka (Maven) | 2.8.0 to before 2.8.2 | 2.8.2 | Patch available | GHSA-c9h3-c6qj-hh7q |
| — | org.apache.kafka:kafka (Maven) | 3.0.0 to before 3.0.2 | 3.0.2 | Patch available | GHSA-c9h3-c6qj-hh7q |
| — | org.apache.kafka:kafka (Maven) | 3.1.0 to before 3.1.2 | 3.1.2 | Patch available | GHSA-c9h3-c6qj-hh7q |
| — | org.apache.kafka:kafka (Maven) | 3.2.0 to before 3.2.3 | 3.2.3 | Patch available | GHSA-c9h3-c6qj-hh7q |
- Apache Kafka VendorApache Affected Apache Kafka 2.8.0 2.8.0 ; Apache Kafka 2.8.1 2.8.1; Apache Kafka 3.0.0 3.0.0; Apache Kafka 3.0.1 3.0.1; Apache Kafka 3.1.0 3.1.0; Apache Kafka 3.1.1 3.1.1; Apache Kafka 3.2.0 3.2.0; Apache Kafka 3.2.1 3.2.1 Fixed in — No fix listed CNA
- org.apache.kafka:kafka (Maven) Vendor— Affected 2.8.0 to before 2.8.2 Fixed in 2.8.2 Patch available GHSA-c9h3-c6qj-hh7q
- org.apache.kafka:kafka (Maven) Vendor— Affected 3.0.0 to before 3.0.2 Fixed in 3.0.2 Patch available GHSA-c9h3-c6qj-hh7q
- org.apache.kafka:kafka (Maven) Vendor— Affected 3.1.0 to before 3.1.2 Fixed in 3.1.2 Patch available GHSA-c9h3-c6qj-hh7q
- org.apache.kafka:kafka (Maven) Vendor— Affected 3.2.0 to before 3.2.3 Fixed in 3.2.3 Patch available GHSA-c9h3-c6qj-hh7q
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:kafka:*:*:*:*:*:*:*:* | 2.8.0 to before 2.8.2; 3.0.0 to before 3.0.2; 3.1.0 to before 3.1.2; 3.2.0 to before 3.2.3 | Vulnerable | Apache |
- cpe:2.3:a:apache:kafka:*:*:*:*:*:*:*:* Versions 2.8.0 to before 2.8.2; 3.0.0 to before 3.0.2; 3.1.0 to before 3.1.2; 3.2.0 to before 3.2.3 Vulnerable ·Apache
Remediation
- Fix · GHSA-c9h3-c6qj-hh7q org.apache.kafka:kafka (Maven) Fixed in 2.8.2 Advisory →
- Fix · GHSA-c9h3-c6qj-hh7q org.apache.kafka:kafka (Maven) Fixed in 3.0.2 Advisory →
- Fix · GHSA-c9h3-c6qj-hh7q org.apache.kafka:kafka (Maven) Fixed in 3.1.2 Advisory →
- Fix · GHSA-c9h3-c6qj-hh7q org.apache.kafka:kafka (Maven) Fixed in 3.2.3 Advisory →
Red Hat 1 advisory
- RHSA-2022:6819 Released 2022-10-05 · Red Hat rating ImportantRed Hat AMQ Streams 2.2.0 release and security update
- Red Hat AMQ Streams 2.2.0
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat AMQ Streams 2.2.0 | Fixed | RHSA-2022:6819 |
Not affected: 1 product
- Red Hat build of Quarkus
Timeline
- 2026-10-02 Threatist record created from CVE-2022-34917
- 2026-10-03 Alias added: GHSA-c9h3-c6qj-hh7q
References
Other 6
- https://github.com/apache/kafka/commit/14951a83e3fdead212156e5532359500d72f68bc
- https://github.com/apache/kafka/commit/2bfa24b2bd416e7b8c4a0c566b984c43904fdecb
- https://github.com/apache/kafka/commit/aaceb6b79bfcb1d32874ccdbc8f3138d1c1c00fb
- https://github.com/apache/kafka/commit/c1295662768e64b4467e27c3d5158f95f2307657
- https://issues.apache.org/jira/browse/KAFKA-14063
- https://kafka.apache.org/cve-list#CVE-2022-34917
More Apache Kafka vulnerabilities
- TI-2025-20589 Apache Kafka Client: Arbitrary file read and SSRF vulnerability CVSS 3.1HIGH 7.5
- TI-2026-25947 Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication CVSS 3.1CRITICAL 9.1
- TI-2018-12295 Improper input validation in Apache Kafka CVSS 3.0HIGH 8.8
- TI-2025-20590 Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration CVSS 3.1HIGH 8.8
- TI-2025-20591 Apache Kafka: Possible RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration CVSS 3.1HIGH 7.5
- TI-2019-09246 Cleartext transmission of sensitive information in Apache Kafka CVSS 3.1HIGH 7.5
Sources
- CVE-2022-34917 · CVE Program
- CVE-2022-34917 · NVD
- FIRST EPSS
- GHSA-c9h3-c6qj-hh7q · GitHub Advisory Database · CC BY 4.0
- CVE-2022-34917 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences