Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-502.
Summary
A possible security vulnerability has been identified in Apache Kafka. This requires access to a alterConfig to the cluster resource, or Kafka Connect worker, and the ability to create/modify connectors on it with an arbitrary Kafka client SASL JAAS config and a SASL-based security protocol, which has been possible on Kafka clusters since Apache Kafka 2.0.0 (Kafka Connect 2.3.0). When configuring the broker via config file or AlterConfig command, or connector via the Kafka Kafka Connect REST API, an authenticated operator can set the `sasl.jaas.config` property for any of the connector's Kafka clients to "com.sun.security.auth.module.LdapLoginModule", which can be done via the `producer.override.sasl.jaas.config`, `consumer.override.sasl.jaas.config`, or `admin.override.sasl.jaas.config` properties. This will allow the server to connect to the attacker's LDAP server and deserialize the LDAP response, which the attacker can use to execute java deserialization gadget chains on the Kafka connect server. Attacker can cause unrestricted deserialization of untrusted data (or) RCE vulnerability when there are gadgets in the classpath. Since Apache Kafka 3.0.0, users are allowed to specify these properties in connector configurations for Kafka Connect clusters running with out-of-the-box configurations. Before Apache Kafka 3.0.0, users may not specify these properties unless the Kafka Connect cluster has been reconfigured with a connector client override policy that permits them. Since Apache Kafka 3.9.1/4.0.0, we have added a system property ("-Dorg.apache.kafka.disallowed.login.modules") to disable the problematic login modules usage in SASL JAAS configuration. Also by default "com.sun.security.auth.module.JndiLoginModule,com.sun.security.auth.module.LdapLoginModule" are disabled in Apache Kafka Connect 3.9.1/4.0.0. We advise the Kafka users to validate connector configurations and only allow trusted LDAP configurations. Also examine connector dependencies for vulnerable versions and either upgrade their connectors, upgrading that specific dependency, or removing the connectors as options for remediation. Finally, in addition to leveraging the "org.apache.kafka.disallowed.login.modules" system property, Kafka Connect users can also implement their own connector client config override policy, which can be used to control which Kafka client properties can be overridden directly in a connector config and which cannot.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Kafka | 2.3.0 – 3.9.0 | — | No fix listed | CNA |
| — | org.apache.kafka:kafka_2.11 (Maven) | 2.3.0 – 2.4.1 | — | No fix listed | GHSA-76qp-h5mr-frr4 |
| — | org.apache.kafka:kafka_2.12 (Maven) | 2.3.0 to before 3.9.1 | 3.9.1 | Patch available | GHSA-76qp-h5mr-frr4 |
| — | org.apache.kafka:kafka_2.13 (Maven) | 2.4.0 to before 3.9.1 | 3.9.1 | Patch available | GHSA-76qp-h5mr-frr4 |
- Apache Kafka VendorApache Affected 2.3.0 – 3.9.0 Fixed in — No fix listed CNA
- org.apache.kafka:kafka_2.11 (Maven) Vendor— Affected 2.3.0 – 2.4.1 Fixed in — No fix listed GHSA-76qp-h5mr-frr4
- org.apache.kafka:kafka_2.12 (Maven) Vendor— Affected 2.3.0 to before 3.9.1 Fixed in 3.9.1 Patch available GHSA-76qp-h5mr-frr4
- org.apache.kafka:kafka_2.13 (Maven) Vendor— Affected 2.4.0 to before 3.9.1 Fixed in 3.9.1 Patch available GHSA-76qp-h5mr-frr4
Remediation
- Fix · GHSA-76qp-h5mr-frr4 org.apache.kafka:kafka_2.12 (Maven) Fixed in 3.9.1 Advisory →
- Fix · GHSA-76qp-h5mr-frr4 org.apache.kafka:kafka_2.13 (Maven) Fixed in 3.9.1 Advisory →
Red Hat 1 advisory
- RHSA-2025:23417 Released 2025-12-16 · Red Hat rating ImportantStreams for Apache Kafka 3.1.0 release and security update
- Streams for Apache Kafka 3.1.0
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Streams for Apache Kafka 3.1.0 | Fixed | RHSA-2025:23417 |
Not affected: 21 products
- A-MQ Clients 2
- Logging Subsystem for Red Hat OpenShift
- OpenShift Serverless
- Red Hat Data Grid 8
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Fuse 7
- Red Hat Integration Camel K 1
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat JBoss Enterprise Application Platform 8
- Red Hat JBoss Enterprise Application Platform Expansion Pack
- Red Hat Process Automation 7
- Red Hat build of Apache Camel 4 for Quarkus 3
- Red Hat build of Apache Camel for Spring Boot 4
- Red Hat build of Apicurio Registry 2
- Red Hat build of Apicurio Registry 3
- Red Hat build of Debezium 2
- Red Hat build of Debezium 3
- Red Hat build of Quarkus
- streams for Apache Kafka
- streams for Apache Kafka 2
Timeline
- 2026-10-02 Threatist record created from CVE-2025-27818
- 2026-10-03 Alias added: GHSA-76qp-h5mr-frr4
References
More Apache Kafka vulnerabilities
- TI-2025-20589 Apache Kafka Client: Arbitrary file read and SSRF vulnerability CVSS 3.1HIGH 7.5
- TI-2026-25947 Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication CVSS 3.1CRITICAL 9.1
- TI-2018-12295 Improper input validation in Apache Kafka CVSS 3.0HIGH 8.8
- TI-2022-15706 Unauthenticated clients may cause OutOfMemoryError on Apache Kafka Brokers CVSS 3.1HIGH 7.5
- TI-2025-20591 Apache Kafka: Possible RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration CVSS 3.1HIGH 7.5
- TI-2019-09246 Cleartext transmission of sensitive information in Apache Kafka CVSS 3.1HIGH 7.5
Sources
- CVE-2025-27818 · CVE Program
- CVE-2025-27818 · NVD
- FIRST EPSS
- GHSA-76qp-h5mr-frr4 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-27818 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences