Read the docs
TI-2022-16138 Aliases CVE-2022-35689GHSA-5fxx-jwjm-x9hj

Adobe Commerce Improper Access Control Security feature bypass

Priority LOW 33CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284.

Summary

Adobe Commerce versions 2.4.4-p1 (and earlier) and 2.4.5 (and earlier) are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to impact the availability of a user's minor feature. Exploitation of this issue does not require user interaction.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01439 73rd percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.4.4-p2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AdobeMagento Commerceup to 2.4.5; up to 2.4.4-p1; up to None—No fix listedCNA
—magento/community-edition (Packagist)2.4.4-p1 to before 2.4.4-p22.4.4-p2Patch availableGHSA-5fxx-jwjm-x9hj
—magento/community-edition (Packagist)——No fix listedGHSA-5fxx-jwjm-x9hj
—magento/community-edition (Packagist)——No fix listedGHSA-5fxx-jwjm-x9hj
—magento/community-edition (Packagist)2.4.3-p1 – 2.4.3-p3—No fix listedGHSA-5fxx-jwjm-x9hj
—magento/community-edition (Packagist)——No fix listedGHSA-5fxx-jwjm-x9hj
—magento/project-community-edition (Packagist)up to 2.0.2—No fix listedGHSA-5fxx-jwjm-x9hj
  • Magento Commerce VendorAdobe Affected up to 2.4.5; up to 2.4.4-p1; up to None Fixed in — No fix listed CNA
  • magento/community-edition (Packagist) Vendor— Affected 2.4.4-p1 to before 2.4.4-p2 Fixed in 2.4.4-p2 Patch available GHSA-5fxx-jwjm-x9hj
  • magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-5fxx-jwjm-x9hj
  • magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-5fxx-jwjm-x9hj
  • magento/community-edition (Packagist) Vendor— Affected 2.4.3-p1 – 2.4.3-p3 Fixed in — No fix listed GHSA-5fxx-jwjm-x9hj
  • magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-5fxx-jwjm-x9hj
  • magento/project-community-edition (Packagist) Vendor— Affected up to 2.0.2 Fixed in — No fix listed GHSA-5fxx-jwjm-x9hj

CPE configurations NVD · 8

CPEVersionsRoleVendor
cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:*before 2.4.4VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:*2.4.4VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.4:p1:*:*:*:*:*:*2.4.4 p1VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.5:-:*:*:*:*:*:*2.4.5VulnerableAdobe
cpe:2.3:a:adobe:magento_open_source:*:*:*:*:*:*:*:*before 2.4.4VulnerableAdobe
cpe:2.3:a:adobe:magento_open_source:2.4.4:-:*:*:*:*:*:*2.4.4VulnerableAdobe
cpe:2.3:a:adobe:magento_open_source:2.4.4:p1:*:*:*:*:*:*2.4.4 p1VulnerableAdobe
cpe:2.3:a:adobe:magento_open_source:2.4.5:-:*:*:*:*:*:*2.4.5VulnerableAdobe
  • cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* Versions before 2.4.4 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.4:p1:*:*:*:*:*:* Versions 2.4.4 p1 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.5:-:*:*:*:*:*:* Versions 2.4.5 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:magento_open_source:*:*:*:*:*:*:*:* Versions before 2.4.4 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:magento_open_source:2.4.4:-:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:magento_open_source:2.4.4:p1:*:*:*:*:*:* Versions 2.4.4 p1 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:magento_open_source:2.4.5:-:*:*:*:*:*:* Versions 2.4.5 Vulnerable ·Adobe

Remediation

  • Fix · GHSA-5fxx-jwjm-x9hj magento/community-edition (Packagist) Fixed in 2.4.4-p2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-35689
  2. 2026-10-03 Alias added: GHSA-5fxx-jwjm-x9hj

References

  • TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-08035 Adobe Commerce checkout improper input validation leads to remote code execution KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-35762 Unrestricted file upload in Adobe Commerce allows code execution KEVCVSS 3.1CRITICAL 9.3
  • TI-2026-50010 Adobe Commerce | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 9.1
  • TI-2025-34067 Adobe Commerce | Improper Input Validation (CWE-20) KEVCVSS 3.1CRITICAL 9.1
See all 213 →

Sources