Adobe Commerce Improper Access Control Security feature bypass
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to leak minor information of another user's account detials. Exploitation of this issue does not require user interaction.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Magento Commerce | up to 2.4.4; up to 2.3.7-p3; up to 2.4.3-p2; up to None | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | 2.4.3-p1 to before 2.4.3-p3 | 2.4.3-p3 | Patch available | GHSA-gm4m-9rm8-7rxj |
| — | magento/community-edition (Packagist) | 2.3.7-p1 to before 2.3.7-p4 | 2.3.7-p4 | Patch available | GHSA-gm4m-9rm8-7rxj |
| — | magento/project-community-edition (Packagist) | up to 2.0.2 | — | No fix listed | GHSA-gm4m-9rm8-7rxj |
| — | magento/community-edition (Packagist) | — | — | No fix listed | GHSA-gm4m-9rm8-7rxj |
| — | magento/community-edition (Packagist) | — | — | No fix listed | GHSA-gm4m-9rm8-7rxj |
| — | magento/community-edition (Packagist) | — | — | No fix listed | GHSA-gm4m-9rm8-7rxj |
- Magento Commerce VendorAdobe Affected up to 2.4.4; up to 2.3.7-p3; up to 2.4.3-p2; up to None Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected 2.4.3-p1 to before 2.4.3-p3 Fixed in 2.4.3-p3 Patch available GHSA-gm4m-9rm8-7rxj
- magento/community-edition (Packagist) Vendor— Affected 2.3.7-p1 to before 2.3.7-p4 Fixed in 2.3.7-p4 Patch available GHSA-gm4m-9rm8-7rxj
- magento/project-community-edition (Packagist) Vendor— Affected up to 2.0.2 Fixed in — No fix listed GHSA-gm4m-9rm8-7rxj
- magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-gm4m-9rm8-7rxj
- magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-gm4m-9rm8-7rxj
- magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-gm4m-9rm8-7rxj
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* | 2.4.0 to before 2.4.4 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_commerce:2.3.7:-:*:*:*:*:*:* | 2.3.7 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_commerce:2.3.7:p1:*:*:*:*:*:* | 2.3.7 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_commerce:2.3.7:p2:*:*:*:*:*:* | 2.3.7 p2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_commerce:2.3.7:p3:*:*:*:*:*:* | 2.3.7 p3 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_commerce:2.4.3:-:*:*:*:*:*:* | 2.4.3 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_commerce:2.4.3:p1:*:*:*:*:*:* | 2.4.3 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_commerce:2.4.3:p2:*:*:*:*:*:* | 2.4.3 p2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_commerce:2.4.4:-:*:*:*:*:*:* | 2.4.4 | Vulnerable | Adobe |
- cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* Versions 2.4.0 to before 2.4.4 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_commerce:2.3.7:-:*:*:*:*:*:* Versions 2.3.7 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_commerce:2.3.7:p1:*:*:*:*:*:* Versions 2.3.7 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_commerce:2.3.7:p2:*:*:*:*:*:* Versions 2.3.7 p2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_commerce:2.3.7:p3:*:*:*:*:*:* Versions 2.3.7 p3 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_commerce:2.4.3:-:*:*:*:*:*:* Versions 2.4.3 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_commerce:2.4.3:p1:*:*:*:*:*:* Versions 2.4.3 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_commerce:2.4.3:p2:*:*:*:*:*:* Versions 2.4.3 p2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_commerce:2.4.4:-:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·Adobe
Remediation
- Fix · GHSA-gm4m-9rm8-7rxj magento/community-edition (Packagist) Fixed in 2.4.3-p3 Advisory →
- Fix · GHSA-gm4m-9rm8-7rxj magento/community-edition (Packagist) Fixed in 2.3.7-p4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-35692
- 2026-10-03 Alias added: GHSA-gm4m-9rm8-7rxj
References
More Adobe Commerce vulnerabilities
- TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
- TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
- TI-2022-08035 Adobe Commerce checkout improper input validation leads to remote code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2026-35762 Unrestricted file upload in Adobe Commerce allows code execution KEVCVSS 3.1CRITICAL 9.3
- TI-2026-50010 Adobe Commerce | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 9.1
- TI-2025-34067 Adobe Commerce | Improper Input Validation (CWE-20) KEVCVSS 3.1CRITICAL 9.1
Sources
- CVE-2022-35692 · CVE Program
- CVE-2022-35692 · NVD
- FIRST EPSS
- GHSA-gm4m-9rm8-7rxj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences