Cross chain utilities for Arbitrum L2 see EOA calls as cross chain calls
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
OpenZeppelin Contracts is a library for secure smart contract development. Contracts using the cross chain utilities for Arbitrum L2, `CrossChainEnabledArbitrumL2` or `LibArbitrumL2`, will classify direct interactions of externally owned accounts (EOAs) as cross chain calls, even though they are not started on L1. This issue has been patched in v4.7.2. Users are advised to upgrade. There are no known workarounds for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenZeppelin | openzeppelin-contracts | 4.6.0 to before 4.7.2 | 4.7.2 | Patch available | CNA |
| — | @openzeppelin/contracts (npm) | 4.6.0 to before 4.7.2 | 4.7.2 | Patch available | GHSA-9j3m-g383-29qr |
| — | @openzeppelin/contracts-upgradeable (npm) | 4.6.0 to before 4.7.2 | 4.7.2 | Patch available | GHSA-9j3m-g383-29qr |
- openzeppelin-contracts VendorOpenZeppelin Affected 4.6.0 to before 4.7.2 Fixed in 4.7.2 Patch available CNA
- @openzeppelin/contracts (npm) Vendor— Affected 4.6.0 to before 4.7.2 Fixed in 4.7.2 Patch available GHSA-9j3m-g383-29qr
- @openzeppelin/contracts-upgradeable (npm) Vendor— Affected 4.6.0 to before 4.7.2 Fixed in 4.7.2 Patch available GHSA-9j3m-g383-29qr
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openzeppelin:contracts:*:*:*:*:*:node.js:*:* | 4.6.0 to before 4.7.2 | Vulnerable | OpenZeppelin |
| cpe:2.3:a:openzeppelin:contracts_upgradeable:*:*:*:*:*:node.js:*:* | 4.6.0 to before 4.7.2 | Vulnerable | OpenZeppelin |
- cpe:2.3:a:openzeppelin:contracts:*:*:*:*:*:node.js:*:* Versions 4.6.0 to before 4.7.2 Vulnerable ·OpenZeppelin
- cpe:2.3:a:openzeppelin:contracts_upgradeable:*:*:*:*:*:node.js:*:* Versions 4.6.0 to before 4.7.2 Vulnerable ·OpenZeppelin
Remediation
- Fix · CNA openzeppelin-contracts (OpenZeppelin) Fixed in 4.7.2
- Fix · GHSA-9j3m-g383-29qr @openzeppelin/contracts (npm) Fixed in 4.7.2 Advisory →
- Fix · GHSA-9j3m-g383-29qr @openzeppelin/contracts-upgradeable (npm) Fixed in 4.7.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-35916
- 2026-10-03 Alias added: GHSA-9j3m-g383-29qr
References
Advisory 2
More OpenZeppelin Contracts vulnerabilities
- TI-2022-13196 OpenZeppelin Contracts for Cairo account cannot process transactions on Goerli CVSS 3.1MEDIUM 6.5
- TI-2021-16554 TimelockController vulnerability in OpenZeppelin Contracts CVSS 3.1CRITICAL 10.0
- TI-2021-16553 TimelockController vulnerability in OpenZeppelin Contracts CVSS 3.1CRITICAL 10.0
- TI-2021-18096 UUPSUpgradeable vulnerability in OpenZeppelin Contracts CVSS 3.1CRITICAL 9.8
- TI-2022-13238 GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts CVSS 3.1HIGH 7.5
- TI-2022-13212 OpenZeppelin Contracts's ERC165Checker may revert instead of returning false CVSS 3.1HIGH 7.5
Sources
- CVE-2022-35916 · CVE Program
- CVE-2022-35916 · NVD
- FIRST EPSS
- GHSA-9j3m-g383-29qr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences