Integer overflow in certain command arguments can drive Redis to OOM panic
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 fixed, 6 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-190 and the CVSS impact.
Summary
Redis is an in-memory database that persists on disk. Authenticated users issuing specially crafted `SETRANGE` and `SORT(_RO)` commands can trigger an integer overflow, resulting with Redis attempting to allocate impossible amounts of memory and abort with an out-of-memory (OOM) panic. The problem is fixed in Redis versions 7.0.8, 6.2.9 and 6.0.17. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Redis | redis | 7.0 to before 7.0.8; 6.2 to before 6.2.9; before 6.0.17 | 7.0.8, 6.2.9, 6.0.17 | Patch available | CNA |
- redis VendorRedis Affected 7.0 to before 7.0.8; 6.2 to before 6.2.9; before 6.0.17 Fixed in 7.0.8, 6.2.9, 6.0.17 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redis:redis:*:*:*:*:*:*:*:* | 6.0.0 to before 6.0.17; 6.2.0 to before 6.2.9; 7.0.0 to before 7.0.8 | Vulnerable | Redis |
- cpe:2.3:a:redis:redis:*:*:*:*:*:*:*:* Versions 6.0.0 to before 6.0.17; 6.2.0 to before 6.2.9; 7.0.0 to before 7.0.8 Vulnerable ·Redis
Remediation
- Fix · CNA redis (redis) Fixed in 7.0.8, 6.2.9, 6.0.17
Red Hat 1 advisory
- RHSA-2025:0595 Released 2025-01-22 · Red Hat rating Importantredis:6 security update
- Red Hat Enterprise Linux AppStream (v. 8) redis-6.2.17-1.module+el8.10.0+22680+748527fd.aarch64::redis:6, redis-6.2.17-1.module+el8.10.0+22680+748527fd.ppc64le::redis:6, redis-6.2.17-1.module+el8.10.0+22680+748527fd.s390x::redis:6 +7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix yet |
| Red Hat Ansible Automation Platform 1.2 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Out of support scope |
| Red Hat Quay 3 | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2025:0595 |
Not affected: 4 products
- Red Hat Advanced Cluster Management for Kubernetes 2
- Red Hat Enterprise Linux 9
- Red Hat Fuse 7
- Red Hat Satellite 6
Timeline
- 2026-10-02 Threatist record created from CVE-2022-35977
References
More Redis vulnerabilities
- TI-2022-00463 Missing authorization in Debian redis KEVCVSS 3.1CRITICAL 10.0
- TI-2025-31759 Redis Lua Use-After-Free may lead to remote code execution CVSS 3.1CRITICAL 10.0
- TI-2023-18618 Heap overflow in COMMAND GETKEYS and ACL evaluation in Redis CVSS 3.1HIGH 8.8
- TI-2024-20813 Lua library commands may lead to stack overflow and RCE in Redis CVSS 3.1HIGH 8.8
- TI-2022-08647 Heap overflow issue with the Lua cjson library used by Redis CVSS 3.1HIGH 8.8
- TI-2022-08549 Lua scripts can be manipulated to overcome ACL rules in Redis CVSS 3.1HIGH 7.8
Sources
- CVE-2022-35977 · CVE Program
- CVE-2022-35977 · NVD
- FIRST EPSS
- CVE-2022-35977 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences