Read the docs
TI-2022-16405 Aliases CVE-2022-35980GHSA-f4qr-f4xx-hjxw

OpenSearch vulnerable to Improper Authorization of Index Containing Sensitive Information

Priority MEDIUM 41CWE-612Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

OpenSearch Security is a plugin for OpenSearch that offers encryption, authentication and authorization. Versions 2.0.0.0 and 2.1.0.0 of the security plugin are affected by an information disclosure vulnerability. Requests to an OpenSearch cluster configured with advanced access control features document level security (DLS), field level security (FLS), and/or field masking will not be filtered when the query's search pattern matches an aliased index. OpenSearch Dashboards creates an alias to `.kibana` by default, so filters with the index pattern of `*` to restrict access to documents or fields will not be applied. This issue allows requests to access sensitive information when customer have acted to restrict access that specific information. OpenSearch 2.2.0, which is compatible with OpenSearch Security 2.2.0.0, contains the fix for this issue. There is no recommended work around.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01231 69th percentileScored 2026-11-07
Fix Fixed org.opensearch.plugin:opensearch-security (Maven): 2.2.0.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AWSsecurity2.0.0.0 – 2.1.0.0—No fix listedCNA
—org.opensearch.plugin:opensearch-security (Maven)2.0.0.0 to before 2.2.0.02.2.0.0Patch availableGHSA-f4qr-f4xx-hjxw
  • security VendorAWS Affected 2.0.0.0 – 2.1.0.0 Fixed in — No fix listed CNA
  • org.opensearch.plugin:opensearch-security (Maven) Vendor— Affected 2.0.0.0 to before 2.2.0.0 Fixed in 2.2.0.0 Patch available GHSA-f4qr-f4xx-hjxw

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:amazon:opensearch:2.0.0:*:*:*:*:docker:*:*2.0.0VulnerableAWS
cpe:2.3:a:amazon:opensearch:2.1.0:*:*:*:*:docker:*:*2.1.0VulnerableAWS
  • cpe:2.3:a:amazon:opensearch:2.0.0:*:*:*:*:docker:*:* Versions 2.0.0 Vulnerable ·AWS
  • cpe:2.3:a:amazon:opensearch:2.1.0:*:*:*:*:docker:*:* Versions 2.1.0 Vulnerable ·AWS

Remediation

  • Fix · GHSA-f4qr-f4xx-hjxw org.opensearch.plugin:opensearch-security (Maven) Fixed in 2.2.0.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-35980
  2. 2026-10-03 Alias added: GHSA-f4qr-f4xx-hjxw

References

  • TI-2022-13159 Unsafe YAML deserialization in opensearch-ruby CVSS 3.1HIGH 8.8
  • TI-2025-08817 OpenSearch 3.2.0 - Nested Boolean/Disjunction asymmetric DoS CVSS 4.0HIGH 8.3
  • TI-2023-09441 Issue with whitespace in JWT roles in OpenSearch CVSS 3.1HIGH 8.8
  • TI-2023-11077 Time discrepancy in authentication responses in OpenSearch CVSS 3.1MEDIUM 5.3
  • TI-2023-09442 Field-level security issue with .keyword fields in OpenSearch CVSS 3.1MEDIUM 6.5
  • TI-2022-20259 Issue with fine-grained access control of indices backing data streams CVSS 3.1MEDIUM 6.3
See all 10 →

Sources