Read the docs
TI-2022-20259 Aliases CVE-2022-41918GHSA-wmx7-x4jp-9jgg

Issue with fine-grained access control of indices backing data streams

Priority LOW 29CWE-612Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

OpenSearch is a community-driven, open source fork of Elasticsearch and Kibana. There is an issue with the implementation of fine-grained access control rules (document-level security, field-level security and field masking) where they are not correctly applied to the indices that back data streams potentially leading to incorrect access authorization. OpenSearch 1.3.7 and 2.4.0 contain a fix for this issue. Users are advised to update. There are no known workarounds for this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00484 41st percentileScored 2026-11-07
Fix Fixed security (opensearch-project): 1.3.7, 2.4.0org.opensearch.plugin:opensearch-security (Maven): 1.3.7, 2.4.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AWSsecuritybefore 1.3.7; 2.0.0 to before 2.4.01.3.7, 2.4.0Patch availableCNA
—org.opensearch.plugin:opensearch-security (Maven)before 1.3.71.3.7Patch availableGHSA-wmx7-x4jp-9jgg
—org.opensearch.plugin:opensearch-security (Maven)2.0.0 to before 2.4.02.4.0Patch availableGHSA-wmx7-x4jp-9jgg
  • security VendorAWS Affected before 1.3.7; 2.0.0 to before 2.4.0 Fixed in 1.3.7, 2.4.0 Patch available CNA
  • org.opensearch.plugin:opensearch-security (Maven) Vendor— Affected before 1.3.7 Fixed in 1.3.7 Patch available GHSA-wmx7-x4jp-9jgg
  • org.opensearch.plugin:opensearch-security (Maven) Vendor— Affected 2.0.0 to before 2.4.0 Fixed in 2.4.0 Patch available GHSA-wmx7-x4jp-9jgg

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:amazon:opensearch:*:*:*:*:*:docker:*:*before 1.3.7; 2.0.0 to before 2.4.0VulnerableAWS
  • cpe:2.3:a:amazon:opensearch:*:*:*:*:*:docker:*:* Versions before 1.3.7; 2.0.0 to before 2.4.0 Vulnerable ·AWS

Remediation

  • Fix · CNA security (opensearch-project) Fixed in 1.3.7, 2.4.0
  • Fix · GHSA-wmx7-x4jp-9jgg org.opensearch.plugin:opensearch-security (Maven) Fixed in 1.3.7 Advisory →
  • Fix · GHSA-wmx7-x4jp-9jgg org.opensearch.plugin:opensearch-security (Maven) Fixed in 2.4.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-41918
  2. 2026-10-03 Alias added: GHSA-wmx7-x4jp-9jgg

References

  • TI-2022-13159 Unsafe YAML deserialization in opensearch-ruby CVSS 3.1HIGH 8.8
  • TI-2025-08817 OpenSearch 3.2.0 - Nested Boolean/Disjunction asymmetric DoS CVSS 4.0HIGH 8.3
  • TI-2022-16405 OpenSearch vulnerable to Improper Authorization of Index Containing Sensitive Information CVSS 3.1HIGH 7.5
  • TI-2023-09441 Issue with whitespace in JWT roles in OpenSearch CVSS 3.1HIGH 8.8
  • TI-2023-11077 Time discrepancy in authentication responses in OpenSearch CVSS 3.1MEDIUM 5.3
  • TI-2023-09442 Field-level security issue with .keyword fields in OpenSearch CVSS 3.1MEDIUM 6.5
See all 10 →

Sources