Read the docs
TI-2022-17606 Aliases CVE-2022-37865GHSA-94rr-4jr5-9h2p

Apache Ivy allows creating/overwriting any file on the system

Priority MEDIUM 51CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · High
Fix status
Partial Red Hat: 1 fixed, 8 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.

Summary

With Apache Ivy 2.4.0 an optional packaging attribute has been introduced that allows artifacts to be unpacked on the fly if they used pack200 or zip packaging. For artifacts using the "zip", "jar" or "war" packaging Ivy prior to 2.5.1 doesn't verify the target path when extracting the archive. An archive containing absolute paths or paths that try to traverse "upwards" using ".." sequences can then write files to any location on the local fie system that the user executing Ivy has write access to. Ivy users of version 2.4.0 to 2.5.0 should upgrade to Ivy 2.5.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02139 82nd percentileScored 2026-11-07
Fix Partial org.apache.ivy:ivy (Maven): 2.5.1Red Hat: 1 advisoryRed Hat: 1 fixed, 8 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Ivy2.4.0 and later; up to 2.5.0—No fix listedCNA
—org.apache.ivy:ivy (Maven)2.4.0 to before 2.5.12.5.1Patch availableGHSA-94rr-4jr5-9h2p
  • Apache Ivy VendorApache Affected 2.4.0 and later; up to 2.5.0 Fixed in — No fix listed CNA
  • org.apache.ivy:ivy (Maven) Vendor— Affected 2.4.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-94rr-4jr5-9h2p

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:ivy:*:*:*:*:*:*:*:*2.4.0 to before 2.5.1VulnerableApache
  • cpe:2.3:a:apache:ivy:*:*:*:*:*:*:*:* Versions 2.4.0 to before 2.5.1 Vulnerable ·Apache

Remediation

  • Fix · GHSA-94rr-4jr5-9h2p org.apache.ivy:ivy (Maven) Fixed in 2.5.1 Advisory →

Red Hat 1 advisory

  • RHSA-2023:2100 Released 2023-05-03 · Red Hat rating Important
    Red Hat Integration Camel for Spring Boot 3.20.1 security update
    • RHINT Camel-Springboot 3.20.1

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Apache Ivy — FEDORA-2023-35f775fd6e

    2 records Highest priority Priority MEDIUM 2 MEDIUM

    Other records, highest priority first

    • TI-2022-17607 Apache Ivy allows path traversal in the presence of a malicious repositoryPriority MEDIUM 43

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Migration Toolkit for Applications 6AffectedNo fix planned: Will not fix
Migration Toolkit for RuntimesAffectedNo fix planned: Will not fix
Red Hat Enterprise Linux 7AffectedNo fix planned: Out of support scope
Red Hat Fuse 7AffectedNo fix planned: Out of support scope
Red Hat Integration Camel K 1AffectedNo fix planned: Will not fix
Red Hat JBoss Data Grid 7AffectedNo fix planned: Out of support scope
Red Hat JBoss Enterprise Application Platform 6AffectedNo fix planned: Out of support scope
Red Hat Software CollectionsAffectedNo fix planned: Will not fix
RHINT Camel-Springboot 3.20.1Fixed RHSA-2023:2100
Not affected: 7 products
  • A-MQ Clients 2
  • Red Hat Data Grid 8
  • Red Hat Integration Camel Quarkus 1
  • Red Hat JBoss Enterprise Application Platform 7
  • Red Hat JBoss Enterprise Application Platform Expansion Pack
  • Red Hat OpenShift Application Runtimes
  • Red Hat Single Sign-On 7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-37865
  2. 2026-10-03 Alias added: GHSA-94rr-4jr5-9h2p

References

  • TI-2022-23117 Apache Ivy: XML External Entity vulnerability in Apache Ivy CVSS 3.1HIGH 8.2
  • TI-2022-17607 Apache Ivy allows path traversal in the presence of a malicious repository CVSS 3.1HIGH 7.5
  • TI-2026-21046 Apache Ivy: PackagerResolver path traversal vulnerability CVSS 3.1MEDIUM 5.4

Sources