Apache Ivy allows path traversal in the presence of a malicious repository
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Partial Red Hat: 1 fixed, 11 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.
Summary
When Apache Ivy downloads artifacts from a repository it stores them in the local file system based on a user-supplied "pattern" that may include placeholders for artifacts coordinates like the organisation, module or version. If said coordinates contain "../" sequences - which are valid characters for Ivy coordinates in general - it is possible the artifacts are stored outside of Ivy's local cache or repository or can overwrite different artifacts inside of the local cache. In order to exploit this vulnerability an attacker needs collaboration by the remote repository as Ivy will issue http requests containing ".." sequences and a "normal" repository will not interpret them as part of the artifact coordinates. Users of Apache Ivy 2.0.0 to 2.5.1 should upgrade to Ivy 2.5.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Ivy | 2.0.0 and later; up to 2.5.0 | — | No fix listed | CNA |
| — | org.apache.ivy:ivy (Maven) | 2.0.0 to before 2.5.1 | 2.5.1 | Patch available | GHSA-wv7w-rj2x-556x |
- Apache Ivy VendorApache Affected 2.0.0 and later; up to 2.5.0 Fixed in — No fix listed CNA
- org.apache.ivy:ivy (Maven) Vendor— Affected 2.0.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-wv7w-rj2x-556x
Remediation
- Fix · GHSA-wv7w-rj2x-556x org.apache.ivy:ivy (Maven) Fixed in 2.5.1 Advisory →
Red Hat 1 advisory
- RHSA-2023:2100 Released 2023-05-03 · Red Hat rating ImportantRed Hat Integration Camel for Spring Boot 3.20.1 security update
- RHINT Camel-Springboot 3.20.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Apache Ivy — FEDORA-2023-35f775fd6e
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2022-17606 Apache Ivy allows creating/overwriting any file on the systemPriority MEDIUM 51
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Migration Toolkit for Applications 6 | Affected | No fix planned: Will not fix |
| Migration Toolkit for Runtimes | Affected | No fix planned: Will not fix |
| Red Hat Data Grid 8 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix yet |
| Red Hat Fuse 7 | Affected | No fix planned: Will not fix |
| Red Hat Integration Camel K 1 | Affected | No fix yet |
| Red Hat Integration Camel Quarkus 1 | Affected | No fix planned: Will not fix |
| Red Hat JBoss Data Grid 7 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Enterprise Application Platform 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Enterprise Application Platform Expansion Pack | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix yet |
| RHINT Camel-Springboot 3.20.1 | Fixed | RHSA-2023:2100 |
Not affected: 5 products
- A-MQ Clients 2
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat OpenShift Application Runtimes
- Red Hat Satellite 6
- Red Hat Single Sign-On 7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-37866
- 2026-10-03 Alias added: GHSA-wv7w-rj2x-556x
References
More Apache Ivy vulnerabilities
- TI-2022-17606 Apache Ivy allows creating/overwriting any file on the system CVSS 3.1CRITICAL 9.1
- TI-2022-23117 Apache Ivy: XML External Entity vulnerability in Apache Ivy CVSS 3.1HIGH 8.2
- TI-2026-21046 Apache Ivy: PackagerResolver path traversal vulnerability CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-37866 · CVE Program
- CVE-2022-37866 · NVD
- FIRST EPSS
- GHSA-wv7w-rj2x-556x · GitHub Advisory Database · CC BY 4.0
- CVE-2022-37866 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences