Parse Server subject to Improper Authentication allowing Auth adapter app ID validation to be circumvented
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 4.10.16, or from 5.0.0 to 5.2.6, validation of the authentication adapter app ID for _Facebook_ and _Spotify_ may be circumvented. Configurations which allow users to authenticate using the Parse Server authentication adapter where `appIds` is set as a string instead of an array of strings authenticate requests from an app with a different app ID than the one specified in the `appIds` configuration. For this vulnerability to be exploited, an attacker needs to be assigned an app ID by the authentication provider which is a sub-set of the server-side configured app ID. This issue is patched in versions 4.10.16 and 5.2.7. There are no known workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | before 4.10.16; 5.0.0 to before 5.2.7 | 4.10.16, 5.2.7 | Patch available | CNA |
| — | parse-server (npm) | before 4.10.16 | 4.10.16 | Patch available | GHSA-r657-33vp-gp22 |
| — | parse-server (npm) | 5.0.0 to before 5.2.7 | 5.2.7 | Patch available | GHSA-r657-33vp-gp22 |
- parse-server Vendorparse-community Affected before 4.10.16; 5.0.0 to before 5.2.7 Fixed in 4.10.16, 5.2.7 Patch available CNA
- parse-server (npm) Vendor— Affected before 4.10.16 Fixed in 4.10.16 Patch available GHSA-r657-33vp-gp22
- parse-server (npm) Vendor— Affected 5.0.0 to before 5.2.7 Fixed in 5.2.7 Patch available GHSA-r657-33vp-gp22
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 4.10.16; 5.0.0 to before 5.2.7 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 4.10.16; 5.0.0 to before 5.2.7 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 4.10.16, 5.2.7
- Fix · GHSA-r657-33vp-gp22 parse-server (npm) Fixed in 4.10.16 Advisory →
- Fix · GHSA-r657-33vp-gp22 parse-server (npm) Fixed in 5.2.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39231
- 2026-10-03 Alias added: GHSA-r657-33vp-gp22
References
Advisory 2
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2022-39231 · CVE Program
- CVE-2022-39231 · NVD
- FIRST EPSS
- GHSA-r657-33vp-gp22 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences