Database log access in ZoneMinder
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure, Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-200 and CWE-287.
Summary
ZoneMinder is a free, open source Closed-circuit television software application. In affected versions the ZoneMinder API Exposes Database Log contents to user without privileges, allows insertion, modification, deletion of logs without System Privileges. Users are advised yo upgrade as soon as possible. Users unable to upgrade should disable database logging.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ZoneMinder | zoneminder | before 1.36.27; 1.37.0 to before 1.37.24 | 1.36.27, 1.37.24 | Patch available | CNA |
- zoneminder VendorZoneMinder Affected before 1.36.27; 1.37.0 to before 1.37.24 Fixed in 1.36.27, 1.37.24 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zoneminder:zoneminder:*:*:*:*:*:*:*:* | up to 1.36.27; 1.37.0 to before 1.37.24 | Vulnerable | ZoneMinder |
- cpe:2.3:a:zoneminder:zoneminder:*:*:*:*:*:*:*:* Versions up to 1.36.27; 1.37.0 to before 1.37.24 Vulnerable ·ZoneMinder
Remediation
- Fix · CNA zoneminder (ZoneMinder) Fixed in 1.36.27, 1.37.24
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39289
References
More Zoneminder vulnerabilities
- TI-2025-40444 ZoneMinder v1.36.34 is vulnerable to Command Injection in web/views/image.php. CVSS 3.1CRITICAL 9.8
- TI-2023-11269 ZoneMinder vulnerable to Missing Authorization CVSS 3.1CRITICAL 9.8
- TI-2022-12167 ZoneMinder before 1.36.13 allows remote code execution via an invalid language. CVSS 3.1CRITICAL 9.8
- TI-2024-29012 ZoneMinder Time-based SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-11270 ZoneMinder contains Local File Inclusion vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-11268 ZoneMinder SQL Injection CVSS 3.1CRITICAL 9.6
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences