ZoneMinder vulnerable to Missing Authorization
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-862.
Summary
ZoneMinder is a free, open source Closed-circuit television software application for Linux which supports IP, USB and Analog cameras. Versions prior to 1.36.33 and 1.37.33 are vulnerable to Unauthenticated Remote Code Execution via Missing Authorization. There are no permissions check on the snapshot action, which expects an id to fetch an existing monitor but can be passed an object to create a new one instead. TriggerOn ends up calling shell_exec using the supplied Id. This issue is fixed in This issue is fixed in versions 1.36.33 and 1.37.33.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ZoneMinder | zoneminder | before 1.36.33; 1.37.0 to before 1.37.33 | 1.36.33, 1.37.33 | Patch available | CNA |
- zoneminder VendorZoneMinder Affected before 1.36.33; 1.37.0 to before 1.37.33 Fixed in 1.36.33, 1.37.33 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zoneminder:zoneminder:*:*:*:*:*:*:*:* | before 1.36.33; 1.37.00 to before 1.37.33 | Vulnerable | ZoneMinder |
- cpe:2.3:a:zoneminder:zoneminder:*:*:*:*:*:*:*:* Versions before 1.36.33; 1.37.00 to before 1.37.33 Vulnerable ·ZoneMinder
Remediation
- Fix · CNA zoneminder (ZoneMinder) Fixed in 1.36.33, 1.37.33
Timeline
- 2026-10-02 Threatist record created from CVE-2023-26035
References
More Zoneminder vulnerabilities
- TI-2025-40444 ZoneMinder v1.36.34 is vulnerable to Command Injection in web/views/image.php. CVSS 3.1CRITICAL 9.8
- TI-2022-18665 Database log access in ZoneMinder CVSS 3.1CRITICAL 9.1
- TI-2022-12167 ZoneMinder before 1.36.13 allows remote code execution via an invalid language. CVSS 3.1CRITICAL 9.8
- TI-2024-29012 ZoneMinder Time-based SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-11270 ZoneMinder contains Local File Inclusion vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-11268 ZoneMinder SQL Injection CVSS 3.1CRITICAL 9.6
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences