Read the docs
TI-2022-18671 Aliases CVE-2022-39295

Improper Neutralization of Alternate XSS Syntax in Knowage-Server

Priority MEDIUM 60CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Knowage is an open source suite for modern business analytics alternative over big data systems. KnowageLabs / Knowage-Server starting with the 6.x branch and prior to versions 7.4.22, 8.0.9, and 8.1.0 is vulnerable to cross-site scripting because the `XSSRequestWrapper::stripXSS` method can be bypassed. Versions 7.4.22, 8.0.9, and 8.1.0 contain patches for this issue. There are no known workarounds.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00714 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Knowage-Server (KnowageLabs): 7.4.22, 8.0.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
KnowageLabsKnowage-Server6.0 to before 7.4.22; 8.0 to before 8.0.97.4.22, 8.0.9Patch availableCNA
  • Knowage-Server VendorKnowageLabs Affected 6.0 to before 7.4.22; 8.0 to before 8.0.9 Fixed in 7.4.22, 8.0.9 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:eng:knowage:*:*:*:*:*:*:*:*6.1.0 to before 7.4.22; 8.0.0 to before 8.0.9VulnerableKnowageLabs
  • cpe:2.3:a:eng:knowage:*:*:*:*:*:*:*:* Versions 6.1.0 to before 7.4.22; 8.0.0 to before 8.0.9 Vulnerable ·KnowageLabs

Remediation

  • Fix · CNA Knowage-Server (KnowageLabs) Fixed in 7.4.22, 8.0.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-39295
  2. 2026-10-11 EPSS moved to the 50th–90th percentile

References

  • TI-2025-37342 Knowage Contains a Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.3
  • TI-2023-20050 Knowage Server vulnerable to path traversal via upload functionality CVSS 3.1CRITICAL 10.0
  • TI-2023-17600 Knowage-Server vulnerable to account validation bypass CVSS 3.1HIGH 7.2
  • TI-2023-19080 Query injection in Knowage server CVSS 3.1HIGH 7.7
  • TI-2023-18613 Knowage-Server vulnerable to Path traversal in download functionalities CVSS 3.1MEDIUM 6.5
  • TI-2019-09881 In Knowage through 6.1.1, an unauthenticated user can bypass access controls and access the entire application. CVSS 3.0CRITICAL 9.8
See all 20 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences