Knowage Server vulnerable to path traversal via upload functionality
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Knowage is an open source analytics and business intelligence suite. Starting in the 6.x.x branch and prior to version 8.1.8, the endpoint `/knowage/restful-services/dossier/importTemplateFile` allows authenticated users to upload `template file` on the server, but does not need any authorization to be reached. When the JSP file is uploaded, the attacker just needs to connect to `/knowageqbeengine/foo.jsp` to gain code execution on the server. By exploiting this vulnerability, an attacker with low privileges can upload a JSP file to the `knowageqbeengine` directory and gain code execution capability on the server. This issue has been patched in Knowage version 8.1.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| KnowageLabs | Knowage-Server | 6.0.0 to before 8.1.8 | 8.1.8 | Patch available | CNA |
- Knowage-Server VendorKnowageLabs Affected 6.0.0 to before 8.1.8 Fixed in 8.1.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:eng:knowage:*:*:*:*:*:*:*:* | 6.1.0 to before 8.1.8 | Vulnerable | KnowageLabs |
- cpe:2.3:a:eng:knowage:*:*:*:*:*:*:*:* Versions 6.1.0 to before 8.1.8 Vulnerable ·KnowageLabs
Remediation
- Fix · CNA Knowage-Server (KnowageLabs) Fixed in 8.1.8
Timeline
- 2026-10-02 Threatist record created from CVE-2023-38702
References
More KnowageLabs Knowage vulnerabilities
- TI-2025-37342 Knowage Contains a Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.3
- TI-2023-17600 Knowage-Server vulnerable to account validation bypass CVSS 3.1HIGH 7.2
- TI-2023-19080 Query injection in Knowage server CVSS 3.1HIGH 7.7
- TI-2023-18613 Knowage-Server vulnerable to Path traversal in download functionalities CVSS 3.1MEDIUM 6.5
- TI-2022-18671 Improper Neutralization of Alternate XSS Syntax in Knowage-Server CVSS 3.1MEDIUM 6.1
- TI-2019-09881 In Knowage through 6.1.1, an unauthenticated user can bypass access controls and access the entire application. CVSS 3.0CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences