Read the docs
TI-2022-18689 Aliases CVE-2022-39313GHSA-h423-w6qv-2wj3

Parse Server crashes when receiving file download request with invalid byte range

Priority MEDIUM 40CWE-1284Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 4.10.17, and prior to 5.2.8 on the 5.x branch, crash when a file download request is received with an invalid byte range, resulting in a Denial of Service. This issue has been patched in versions 4.10.17, and 5.2.8. There are no known workarounds.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00814 57th percentileScored 2026-11-07
Fix Fixed parse-server (parse-community): 4.10.17, 5.2.8parse-server (npm): 4.10.17, 5.2.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
parse-communityparse-serverbefore 4.10.17; 5.0.0 to before 5.2.84.10.17, 5.2.8Patch availableCNA
—parse-server (npm)before 4.10.174.10.17Patch availableGHSA-h423-w6qv-2wj3
—parse-server (npm)5.0.0 to before 5.2.85.2.8Patch availableGHSA-h423-w6qv-2wj3
  • parse-server Vendorparse-community Affected before 4.10.17; 5.0.0 to before 5.2.8 Fixed in 4.10.17, 5.2.8 Patch available CNA
  • parse-server (npm) Vendor— Affected before 4.10.17 Fixed in 4.10.17 Patch available GHSA-h423-w6qv-2wj3
  • parse-server (npm) Vendor— Affected 5.0.0 to before 5.2.8 Fixed in 5.2.8 Patch available GHSA-h423-w6qv-2wj3

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:*before 4.10.17; 5.0.0 to before 5.2.8Vulnerableparse-community
  • cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 4.10.17; 5.0.0 to before 5.2.8 Vulnerable ·parse-community

Remediation

  • Fix · CNA parse-server (parse-community) Fixed in 4.10.17, 5.2.8
  • Fix · GHSA-h423-w6qv-2wj3 parse-server (npm) Fixed in 4.10.17 Advisory →
  • Fix · GHSA-h423-w6qv-2wj3 parse-server (npm) Fixed in 5.2.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-39313
  2. 2026-10-03 Alias added: GHSA-h423-w6qv-2wj3

References

  • TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
  • TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
  • TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
  • TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
  • TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
See all 101 →

Sources