Cross-site scripting in moodle
Priority LOW 32CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an XSS risk or a page failing to load.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00716 53rd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.17, 3.11.10, 4.0.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.0 to 4.0.3, 3.11 to 3.11.9, 3.9 to 3.9.16 and earlier unsupported versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.9 to before 3.9.17 | 3.9.17 | Patch available | GHSA-jqgr-gh62-jf53 |
| — | moodle/moodle (Packagist) | 3.11 to before 3.11.10 | 3.11.10 | Patch available | GHSA-jqgr-gh62-jf53 |
| — | moodle/moodle (Packagist) | 4.0 to before 4.0.4 | 4.0.4 | Patch available | GHSA-jqgr-gh62-jf53 |
- moodle Vendor— Affected 4.0 to 4.0.3, 3.11 to 3.11.9, 3.9 to 3.9.16 and earlier unsupported versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.17 Fixed in 3.9.17 Patch available GHSA-jqgr-gh62-jf53
- moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.10 Fixed in 3.11.10 Patch available GHSA-jqgr-gh62-jf53
- moodle/moodle (Packagist) Vendor— Affected 4.0 to before 4.0.4 Fixed in 4.0.4 Patch available GHSA-jqgr-gh62-jf53
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.9.0 to before 3.9.17; 3.11.0 to before 3.11.10; 4.0.0 to before 4.0.4 | Vulnerable | Moodle |
| cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 to before 3.9.17; 3.11.0 to before 3.11.10; 4.0.0 to before 4.0.4 Vulnerable ·Moodle
- cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-jqgr-gh62-jf53 moodle/moodle (Packagist) Fixed in 3.9.17 Advisory →
- Fix · GHSA-jqgr-gh62-jf53 moodle/moodle (Packagist) Fixed in 3.11.10 Advisory →
- Fix · GHSA-jqgr-gh62-jf53 moodle/moodle (Packagist) Fixed in 4.0.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-40313
- 2026-10-03 Alias added: GHSA-jqgr-gh62-jf53
- 2026-10-12 EPSS moved to the 50th–90th percentile
References
Sources
- CVE-2022-40313 · CVE Program
- CVE-2022-40313 · NVD
- FIRST EPSS
- GHSA-jqgr-gh62-jf53 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-40313 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences