A limited SQL injection risk was identified in the "browse list of users" site administration page.
Priority MEDIUM 51CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
A limited SQL injection risk was identified in the "browse list of users" site administration page.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01112 66th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.17, 3.11.10, 4.0.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.0 to 4.0.3, 3.11 to 3.11.9, 3.9 to 3.9.16 and earlier unsupported versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.9 to before 3.9.17 | 3.9.17 | Patch available | GHSA-mqw9-3cjm-xwp3 |
| — | moodle/moodle (Packagist) | 3.11 to before 3.11.10 | 3.11.10 | Patch available | GHSA-mqw9-3cjm-xwp3 |
| — | moodle/moodle (Packagist) | 4.0 to before 4.0.4 | 4.0.4 | Patch available | GHSA-mqw9-3cjm-xwp3 |
- moodle Vendor— Affected 4.0 to 4.0.3, 3.11 to 3.11.9, 3.9 to 3.9.16 and earlier unsupported versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.17 Fixed in 3.9.17 Patch available GHSA-mqw9-3cjm-xwp3
- moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.10 Fixed in 3.11.10 Patch available GHSA-mqw9-3cjm-xwp3
- moodle/moodle (Packagist) Vendor— Affected 4.0 to before 4.0.4 Fixed in 4.0.4 Patch available GHSA-mqw9-3cjm-xwp3
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.9.0 to before 3.9.17; 3.11.0 to before 3.11.10; 4.0.0 to before 4.0.4 | Vulnerable | Moodle |
| cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 to before 3.9.17; 3.11.0 to before 3.11.10; 4.0.0 to before 4.0.4 Vulnerable ·Moodle
- cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-mqw9-3cjm-xwp3 moodle/moodle (Packagist) Fixed in 3.9.17 Advisory →
- Fix · GHSA-mqw9-3cjm-xwp3 moodle/moodle (Packagist) Fixed in 3.11.10 Advisory →
- Fix · GHSA-mqw9-3cjm-xwp3 moodle/moodle (Packagist) Fixed in 4.0.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-40315
- 2026-10-03 Alias added: GHSA-mqw9-3cjm-xwp3
References
Sources
- CVE-2022-40315 · CVE Program
- CVE-2022-40315 · NVD
- FIRST EPSS
- GHSA-mqw9-3cjm-xwp3 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-40315 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences