Zammad 5.2.1 has a fine-grained permission model that allows to configure read-only…
Priority LOW 21CWE-732Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
Zammad 5.2.1 has a fine-grained permission model that allows to configure read-only access to tickets. However, agents were still wrongly able to perform some operations on such tickets, like adding and removing links, tags. and related answers. This issue has been fixed in 5.2.2.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00494 42nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zammad:zammad:*:*:*:*:*:*:*:* | 5.2.0 to before 5.2.2 | Vulnerable | Zammad GmbH |
- cpe:2.3:a:zammad:zammad:*:*:*:*:*:*:*:* Versions 5.2.0 to before 5.2.2 Vulnerable ·Zammad GmbH
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-40817
- 2026-10-03 Alias added: GHSA-h8xg-c9f9-hpm2
References
More Zammad GmbH Zammad vulnerabilities
- TI-2026-65406 Local privilege escalation in Zammad v1.5.0 to v7.2.2 installed via DEB or RPM package KEVCVSS 4.0CRITICAL 9.4
- TI-2026-65405 Undisclosed RCE in Zammad v6.3 and higher KEVCVSS 4.0CRITICAL 9.4
- TI-2024-22252 An issue was discovered in Zammad before 6.3.0. CVSS 3.1CRITICAL 9.1
- TI-2022-23785 A vulnerability in Zammad v5.3.0 allows attackers to execute arbitrary code or escalate… CVSS 3.1CRITICAL 9.8
- TI-2021-18599 An issue was discovered in Zammad before 4.1.1. CVSS 3.1CRITICAL 9.8
- TI-2021-18603 An issue was discovered in Zammad before 4.1.1. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-40817 · CVE Program
- CVE-2022-40817 · NVD
- FIRST EPSS
- GHSA-h8xg-c9f9-hpm2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences