Read the docs
TI-2022-19739 Aliases CVE-2022-41229GHSA-fq2h-r2h9-pj8r

Cross-site scripting in Jenkins NS-ND Integration Performance Publisher Plugin

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.134 and earlier does not escape configuration options of the Execute NetStorm/NetCloud Test build step, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00621 50th percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:cavisson-ns-nd-integration (Maven): 4.8.0.147

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins NS-ND Integration Performance Publisher Pluginup to 4.8.0.134—No fix listedCNA
—io.jenkins.plugins:cavisson-ns-nd-integration (Maven)before 4.8.0.1474.8.0.147Patch availableGHSA-fq2h-r2h9-pj8r
  • Jenkins NS-ND Integration Performance Publisher Plugin VendorJenkins Affected up to 4.8.0.134 Fixed in — No fix listed CNA
  • io.jenkins.plugins:cavisson-ns-nd-integration (Maven) Vendor— Affected before 4.8.0.147 Fixed in 4.8.0.147 Patch available GHSA-fq2h-r2h9-pj8r

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:ns-nd_integration_performance_publisher:*:*:*:*:*:jenkins:*:*up to 4.8.0.134VulnerableJenkins
  • cpe:2.3:a:jenkins:ns-nd_integration_performance_publisher:*:*:*:*:*:jenkins:*:* Versions up to 4.8.0.134 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-fq2h-r2h9-pj8r io.jenkins.plugins:cavisson-ns-nd-integration (Maven) Fixed in 4.8.0.147 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-41229
  2. 2026-10-03 Alias added: GHSA-fq2h-r2h9-pj8r
  3. 2026-11-07 EPSS moved to the 50th–90th percentile

References

  • TI-2022-19738 Missing authorization in Jenkins NS-ND Integration Performance Publisher Plugin CVSS 3.1HIGH 8.8
  • TI-2022-19737 Cross-site request forgery in Jenkins NS-ND Integration Performance Publisher Plugin CVSS 3.1HIGH 8.8
  • TI-2023-16188 Insufficiently protected credentials in Jenkins NS-ND Integration Performance Publisher… CVSS 3.1HIGH 7.5
  • TI-2022-22357 Improper certificate validation in Jenkins NS-ND Integration Performance Publisher Plugin CVSS 3.1HIGH 7.5
  • TI-2022-18199 Improper certificate validation in Jenkins NS-ND Integration Performance Publisher Plugin CVSS 3.1HIGH 7.5
  • TI-2022-22358 Insufficiently protected credentials in Jenkins NS-ND Integration Performance Publisher… CVSS 3.1MEDIUM 6.5
See all 7 →

Sources