[CVE-2021-36032] Magento IDOR Leads to Account Takeover
Priority MEDIUM 41CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Incorrect Authorization vulnerability. An authenticated attacker can exploit this vulnerability to achieve information exposure and privilege escalation.
Why it matters now
EPSS 0.01348 71st percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.3.7-p4, 2.4.3-p3, 2.4.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Adobe Commerce | up to 2.4.3-p2 | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | before 2.3.7-p4 | 2.3.7-p4 | Patch available | GHSA-297f-r9w7-w492 |
| — | magento/community-edition (Packagist) | 2.4.0 to before 2.4.3-p3 | 2.4.3-p3 | Patch available | GHSA-297f-r9w7-w492 |
| — | magento/community-edition (Packagist) | 2.4.4 to before 2.4.5 | 2.4.5 | Patch available | GHSA-297f-r9w7-w492 |
- Adobe Commerce VendorAdobe Affected up to 2.4.3-p2 Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected before 2.3.7-p4 Fixed in 2.3.7-p4 Patch available GHSA-297f-r9w7-w492
- magento/community-edition (Packagist) Vendor— Affected 2.4.0 to before 2.4.3-p3 Fixed in 2.4.3-p3 Patch available GHSA-297f-r9w7-w492
- magento/community-edition (Packagist) Vendor— Affected 2.4.4 to before 2.4.5 Fixed in 2.4.5 Patch available GHSA-297f-r9w7-w492
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* | before 2.3.7; 2.4.0 to before 2.4.3 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.3.7:-:*:*:*:*:*:* | 2.3.7 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.3.7:p1:*:*:*:*:*:* | 2.3.7 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.3.7:p2:*:*:*:*:*:* | 2.3.7 p2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.3.7:p3:*:*:*:*:*:* | 2.3.7 p3 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.3:-:*:*:*:*:*:* | 2.4.3 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.3:p1:*:*:*:*:*:* | 2.4.3 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.3:p2:*:*:*:*:*:* | 2.4.3 p2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:* | 2.4.4 | Vulnerable | Adobe |
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | before 2.3.7; 2.4.0 to before 2.4.3 | Vulnerable | Magento |
- cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* Versions before 2.3.7; 2.4.0 to before 2.4.3 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.3.7:-:*:*:*:*:*:* Versions 2.3.7 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.3.7:p1:*:*:*:*:*:* Versions 2.3.7 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.3.7:p2:*:*:*:*:*:* Versions 2.3.7 p2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.3.7:p3:*:*:*:*:*:* Versions 2.3.7 p3 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.3:-:*:*:*:*:*:* Versions 2.4.3 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.3:p1:*:*:*:*:*:* Versions 2.4.3 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.3:p2:*:*:*:*:*:* Versions 2.4.3 p2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·Adobe
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions before 2.3.7; 2.4.0 to before 2.4.3 Vulnerable ·Magento
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:magento:magento:2.3.7:-:*:*:open_source:*:*:* | 2.3.7 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.7:p1:*:*:open_source:*:*:* | 2.3.7 p1 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.7:p2:*:*:open_source:*:*:* | 2.3.7 p2 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.7:p3:*:*:open_source:*:*:* | 2.3.7 p3 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.4.3:-:*:*:open_source:*:*:* | 2.4.3 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.4.3:p1:*:*:open_source:*:*:* | 2.4.3 p1 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.4.3:p2:*:*:open_source:*:*:* | 2.4.3 p2 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.4.4:-:*:*:open_source:*:*:* | 2.4.4 | Vulnerable | Magento |
- cpe:2.3:a:magento:magento:2.3.7:-:*:*:open_source:*:*:* Versions 2.3.7 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.7:p1:*:*:open_source:*:*:* Versions 2.3.7 p1 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.7:p2:*:*:open_source:*:*:* Versions 2.3.7 p2 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.7:p3:*:*:open_source:*:*:* Versions 2.3.7 p3 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.4.3:-:*:*:open_source:*:*:* Versions 2.4.3 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.4.3:p1:*:*:open_source:*:*:* Versions 2.4.3 p1 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.4.3:p2:*:*:open_source:*:*:* Versions 2.4.3 p2 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.4.4:-:*:*:open_source:*:*:* Versions 2.4.4 Vulnerable ·Magento
Remediation
- Fix · GHSA-297f-r9w7-w492 magento/community-edition (Packagist) Fixed in 2.3.7-p4 Advisory →
- Fix · GHSA-297f-r9w7-w492 magento/community-edition (Packagist) Fixed in 2.4.3-p3 Advisory →
- Fix · GHSA-297f-r9w7-w492 magento/community-edition (Packagist) Fixed in 2.4.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-42344
- 2026-10-03 Alias added: GHSA-297f-r9w7-w492
References
More Adobe Commerce vulnerabilities
- TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
- TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
- TI-2022-08035 Adobe Commerce checkout improper input validation leads to remote code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2026-35762 Unrestricted file upload in Adobe Commerce allows code execution KEVCVSS 3.1CRITICAL 9.3
- TI-2026-50010 Adobe Commerce | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 9.1
- TI-2025-34067 Adobe Commerce | Improper Input Validation (CWE-20) KEVCVSS 3.1CRITICAL 9.1
Sources
- CVE-2022-42344 · CVE Program
- CVE-2022-42344 · NVD
- FIRST EPSS
- GHSA-297f-r9w7-w492 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences