Read the docs
TI-2022-22223 Aliases CVE-2022-45149GHSA-8v23-w4w5-w83c

Cross-site request forgery in Moodle

Priority LOW 25CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

A vulnerability was found in Moodle which exists due to insufficient validation of the HTTP request origin in course redirect URL. A user's CSRF token was unnecessarily included in the URL when being redirected to a course they have just restored. A remote attacker can trick the victim to visit a specially crafted web page and perform arbitrary actions on behalf of the victim on the vulnerable website. This flaw allows an attacker to perform cross-site request forgery attacks.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00441 38th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.18, 3.11.11, 4.0.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—MoodleFixed in moodle 4.0.5, moodle 3.11.11, moodle 3.9.18—No fix listedCNA
—moodle/moodle (Packagist)3.9.0 to before 3.9.183.9.18Patch availableGHSA-8v23-w4w5-w83c
—moodle/moodle (Packagist)3.11.0 to before 3.11.113.11.11Patch availableGHSA-8v23-w4w5-w83c
—moodle/moodle (Packagist)4.0.0 to before 4.0.54.0.5Patch availableGHSA-8v23-w4w5-w83c
  • Moodle Vendor— Affected Fixed in moodle 4.0.5, moodle 3.11.11, moodle 3.9.18 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.9.0 to before 3.9.18 Fixed in 3.9.18 Patch available GHSA-8v23-w4w5-w83c
  • moodle/moodle (Packagist) Vendor— Affected 3.11.0 to before 3.11.11 Fixed in 3.11.11 Patch available GHSA-8v23-w4w5-w83c
  • moodle/moodle (Packagist) Vendor— Affected 4.0.0 to before 4.0.5 Fixed in 4.0.5 Patch available GHSA-8v23-w4w5-w83c

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.9.0 to before 3.9.18; 3.11.0 to before 3.11.11; 4.0.0 to before 4.0.5VulnerableMoodle
cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*35VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*36VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:*37VulnerableFedoraproject
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 to before 3.9.18; 3.11.0 to before 3.11.11; 4.0.0 to before 4.0.5 Vulnerable ·Moodle
  • cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject

Remediation

  • Fix · GHSA-8v23-w4w5-w83c moodle/moodle (Packagist) Fixed in 3.9.18 Advisory →
  • Fix · GHSA-8v23-w4w5-w83c moodle/moodle (Packagist) Fixed in 3.11.11 Advisory →
  • Fix · GHSA-8v23-w4w5-w83c moodle/moodle (Packagist) Fixed in 4.0.5 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-45149
  2. 2026-10-03 Alias added: GHSA-8v23-w4w5-w83c

References

Sources