Cross-site scripting in Moodle
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The stored-XSS vulnerability was discovered in Moodle which exists due to insufficient sanitization of user-supplied data in several "social" user profile fields. An attacker could inject and execute arbitrary HTML and script code in user's browser in context of vulnerable website.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00712 53rd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.11.11, 4.0.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Moodle | Fixed in moodle 4.0.5, moodle 3.11.11 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.11 to before 3.11.11 | 3.11.11 | Patch available | GHSA-xv72-6pgh-cjj8 |
| — | moodle/moodle (Packagist) | 4.0 to before 4.0.5 | 4.0.5 | Patch available | GHSA-xv72-6pgh-cjj8 |
- Moodle Vendor— Affected Fixed in moodle 4.0.5, moodle 3.11.11 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.11 Fixed in 3.11.11 Patch available GHSA-xv72-6pgh-cjj8
- moodle/moodle (Packagist) Vendor— Affected 4.0 to before 4.0.5 Fixed in 4.0.5 Patch available GHSA-xv72-6pgh-cjj8
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.11.0 to before 3.11.11; 4.0.0 to before 4.0.5 | Vulnerable | Moodle |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.11.0 to before 3.11.11; 4.0.0 to before 4.0.5 Vulnerable ·Moodle
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-xv72-6pgh-cjj8 moodle/moodle (Packagist) Fixed in 3.11.11 Advisory →
- Fix · GHSA-xv72-6pgh-cjj8 moodle/moodle (Packagist) Fixed in 4.0.5 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-45151
- 2026-10-03 Alias added: GHSA-xv72-6pgh-cjj8
References
Advisory 4
Other 7
- https://bugzilla.redhat.com/show_bug.cgi?id=2142774
- https://moodle.org/mod/forum/discuss.php?d=440771
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-76131
- https://github.com/moodle/moodle
- https://lists.fedoraproject.org/archives/list/[email protected]/message/2DHYIIAUXUBHMBEDYU7TYNZXEN2W2SA2
- https://lists.fedoraproject.org/archives/list/[email protected]/message/74SXNGA5RIWM7QNX7H3G7SYIQLP4UUGV
- https://lists.fedoraproject.org/archives/list/[email protected]/message/NLRJB5JNKK3VVBLV3NH3RI7COEDAXSAB
Sources
- CVE-2022-45151 · CVE Program
- CVE-2022-45151 · NVD
- FIRST EPSS
- GHSA-xv72-6pgh-cjj8 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-45151 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences