Read the docs
TI-2022-22226 Aliases CVE-2022-45152GHSA-xqcf-vgqc-pcmg

Server-side request forgery in Moodle

Priority MEDIUM 50CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

A blind Server-Side Request Forgery (SSRF) vulnerability was found in Moodle. This flaw exists due to insufficient validation of user-supplied input in LTI provider library. The library does not utilise Moodle's inbuilt cURL helper, which resulted in a blind SSRF risk. An attacker can send a specially crafted HTTP request and trick the application to initiate requests to arbitrary systems. This vulnerability allows a remote attacker to perform SSRF attacks.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0147 73rd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.18, 3.11.11, 4.0.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—MoodleFixed in moodle 4.0.5, moodle 3.11.11, moodle 3.9.18—No fix listedCNA
—moodle/moodle (Packagist)3.9 to before 3.9.183.9.18Patch availableGHSA-xqcf-vgqc-pcmg
—moodle/moodle (Packagist)3.11 to before 3.11.113.11.11Patch availableGHSA-xqcf-vgqc-pcmg
—moodle/moodle (Packagist)4.0 to before 4.0.54.0.5Patch availableGHSA-xqcf-vgqc-pcmg
  • Moodle Vendor— Affected Fixed in moodle 4.0.5, moodle 3.11.11, moodle 3.9.18 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.18 Fixed in 3.9.18 Patch available GHSA-xqcf-vgqc-pcmg
  • moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.11 Fixed in 3.11.11 Patch available GHSA-xqcf-vgqc-pcmg
  • moodle/moodle (Packagist) Vendor— Affected 4.0 to before 4.0.5 Fixed in 4.0.5 Patch available GHSA-xqcf-vgqc-pcmg

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 3.9.18; 3.11.0 to before 3.11.11; 4.0.0 to before 4.0.5VulnerableMoodle
cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:7.0:*:*:*:*:*:*:*7.0VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*35VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*36VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:*37VulnerableFedoraproject
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 3.9.18; 3.11.0 to before 3.11.11; 4.0.0 to before 4.0.5 Vulnerable ·Moodle
  • cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject

Remediation

  • Fix · GHSA-xqcf-vgqc-pcmg moodle/moodle (Packagist) Fixed in 3.9.18 Advisory →
  • Fix · GHSA-xqcf-vgqc-pcmg moodle/moodle (Packagist) Fixed in 3.11.11 Advisory →
  • Fix · GHSA-xqcf-vgqc-pcmg moodle/moodle (Packagist) Fixed in 4.0.5 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-45152
  2. 2026-10-03 Alias added: GHSA-xqcf-vgqc-pcmg

References

Sources