Read the docs
TI-2022-23055 Aliases CVE-2022-46648GHSA-pfpr-3463-c6jh

Code injection in ruby-git

Priority MEDIUM 40CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-94.

Summary

ruby-git versions prior to v1.13.0 allows a remote authenticated attacker to execute an arbitrary ruby code by having a user to load a repository containing a specially crafted filename to the product. This vulnerability is different from CVE-2022-47318.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01414 72nd percentileScored 2026-11-07
Fix Fixed ruby-git (ruby-git): v1.13.0git (RubyGems): 1.13.0Red Hat: 4 advisories

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ruby-gitruby-gitbefore v1.13.0v1.13.0Patch availableCNA
—git (RubyGems)1.2.0 to before 1.13.01.13.0Patch availableGHSA-pfpr-3463-c6jh
  • ruby-git Vendorruby-git Affected before v1.13.0 Fixed in v1.13.0 Patch available CNA
  • git (RubyGems) Vendor— Affected 1.2.0 to before 1.13.0 Fixed in 1.13.0 Patch available GHSA-pfpr-3463-c6jh

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:ruby-git_project:ruby-git:*:*:*:*:*:*:*:*before 1.13.0VulnerableRuby-git Project
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
  • cpe:2.3:a:ruby-git_project:ruby-git:*:*:*:*:*:*:*:* Versions before 1.13.0 Vulnerable ·Ruby-git Project
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian

Remediation

  • Fix · CNA ruby-git (ruby-git) Fixed in v1.13.0
  • Fix · GHSA-pfpr-3463-c6jh git (RubyGems) Fixed in 1.13.0 Advisory →

Red Hat 4 advisories

  • RHSA-2023:6818 Released 2023-11-08 · Red Hat rating Important
    Satellite 6.14 security and bug fix update
    • Red Hat Satellite 6.14 for RHEL 8 foreman-3.7.0.9-1.el8sat, foreman-cli-3.7.0.9-1.el8sat, foreman-debug-3.7.0.9-1.el8sat +33
  • RHSA-2023:5980 Released 2023-10-20 · Red Hat rating Important
    Satellite 6.11.5.6 async security update
    • Red Hat Satellite 6.11 for RHEL 7 foreman-3.1.1.27-1.el7sat, foreman-cli-3.1.1.27-1.el7sat, foreman-debug-3.1.1.27-1.el7sat +14
    • Red Hat Satellite 6.11 for RHEL 8 foreman-3.1.1.27-1.el8sat, foreman-cli-3.1.1.27-1.el8sat, foreman-debug-3.1.1.27-1.el8sat +14
  • RHSA-2023:5979 Released 2023-10-20 · Red Hat rating Important
    Satellite 6.12.5.2 Async Security Update
    • Red Hat Satellite 6.12 for RHEL 8 foreman-3.3.0.23-1.el8sat, puppet-agent-7.26.0-3.el8sat, rubygem-git-1.18.0-1.el8sat +2
Show 1 more Red Hat advisories
  • RHSA-2023:5931 Released 2023-10-19 · Red Hat rating Important
    Satellite 6.13.5 Async Security Update
    • Red Hat Satellite 6.13 for RHEL 8 foreman-3.5.1.23-1.el8sat, foreman-cli-3.5.1.23-1.el8sat, foreman-debug-3.5.1.23-1.el8sat +17

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Satellite 6.11 for RHEL 7Fixed RHSA-2023:5980
Red Hat Satellite 6.11 for RHEL 8Fixed RHSA-2023:5980
Red Hat Satellite 6.12 for RHEL 8Fixed RHSA-2023:5979
Red Hat Satellite 6.13 for RHEL 8Fixed RHSA-2023:5931
Red Hat Satellite 6.14 for RHEL 8Fixed RHSA-2023:6818
Not affected: 5 products
  • Red Hat Satellite 6.11 for RHEL 7
  • Red Hat Satellite 6.11 for RHEL 8
  • Red Hat Satellite 6.12 for RHEL 8
  • Red Hat Satellite 6.13 for RHEL 8
  • Red Hat Satellite 6.14 for RHEL 8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-46648
  2. 2026-10-03 Alias added: GHSA-pfpr-3463-c6jh

References

Sources