Cleartext transmission of sensitive information in Jenkins Gitea Plugin
Priority LOW 20CWE-319Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-319.
Summary
In Jenkins Gitea Plugin 1.4.4 and earlier, the implementation of Gitea personal access tokens did not support credentials masking, potentially exposing them through the build log.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00379 32nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:gitea (Maven): 1.4.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Gitea Plugin | up to 1.4.4 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:gitea (Maven) | before 1.4.5 | 1.4.5 | Patch available | GHSA-x3qh-53qf-jxq9 |
- Jenkins Gitea Plugin VendorJenkins Affected up to 1.4.4 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:gitea (Maven) Vendor— Affected before 1.4.5 Fixed in 1.4.5 Patch available GHSA-x3qh-53qf-jxq9
Remediation
- Fix · GHSA-x3qh-53qf-jxq9 org.jenkins-ci.plugins:gitea (Maven) Fixed in 1.4.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-46685
- 2026-10-03 Alias added: GHSA-x3qh-53qf-jxq9
References
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2022-46685 · CVE Program
- CVE-2022-46685 · NVD
- FIRST EPSS
- GHSA-x3qh-53qf-jxq9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences