Mayan EDMS Tag XSS
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An XSS vulnerability was discovered in the Mayan EDMS DMS. Successful XSS exploitation was observed in the in-product tagging system.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00536 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed mayan-edms (PyPI): 4.3.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mayan EDMS | Mayan EDMS | 4.3.3 and later | — | No fix listed | CNA |
| — | mayan-edms (PyPI) | before 4.3.6 | 4.3.6 | Patch available | GHSA-5m6v-2xgf-qhrw |
- Mayan EDMS VendorMayan EDMS Affected 4.3.3 and later Fixed in — No fix listed CNA
- mayan-edms (PyPI) Vendor— Affected before 4.3.6 Fixed in 4.3.6 Patch available GHSA-5m6v-2xgf-qhrw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mayan-edms:mayan_edms:4.3.3:*:*:*:*:*:*:* | 4.3.3 | Vulnerable | Mayan EDMS |
- cpe:2.3:a:mayan-edms:mayan_edms:4.3.3:*:*:*:*:*:*:* Versions 4.3.3 Vulnerable ·Mayan EDMS
Remediation
- Fix · GHSA-5m6v-2xgf-qhrw mayan-edms (PyPI) Fixed in 4.3.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-47419
- 2026-10-03 Alias added: GHSA-5m6v-2xgf-qhrw
References
Exploit 1
Advisory 2
More Mayan Edms vulnerabilities
- TI-2025-13414 Mayan EDMS authentication redirect CVSS 4.0MEDIUM 5.3
- TI-2025-13413 Mayan EDMS authentication cross site scripting CVSS 4.0MEDIUM 5.3
- TI-2018-11759 An issue was discovered in Mayan EDMS before 3.0.3. CVSS 3.0MEDIUM 6.1
- TI-2018-11758 An issue was discovered in Mayan EDMS before 3.0.2. CVSS 3.0MEDIUM 6.1
- TI-2018-11757 An issue was discovered in Mayan EDMS before 3.0.2. CVSS 3.0MEDIUM 6.1
- TI-2014-03118 Multiple cross-site scripting (XSS) vulnerabilities in… CVSS 2.0LOW 3.5
Sources
- CVE-2022-47419 · CVE Program
- CVE-2022-47419 · NVD
- FIRST EPSS
- GHSA-5m6v-2xgf-qhrw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences