Mayan EDMS authentication cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting, Code execution
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79 and CWE-94.
Summary
A vulnerability was detected in Mayan EDMS up to 4.10.1. The affected element is an unknown function of the file /authentication/. The manipulation results in cross site scripting. The attack may be performed from remote. The exploit is now public and may be used. Upgrading to version 4.10.2 is sufficient to fix this issue. You should upgrade the affected component. The vendor confirms that this is "[f]ixed in version 4.10.2". Furthermore, that "[b]ackports for older versions in process and will be out as soon as their respective CI pipelines complete."
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mayan | EDMS | 4.10.0; 4.10.1 | 4.10.2 | Patch available | CNA |
| — | mayan-edms (PyPI) | 4.10.0 to before 4.10.2 | 4.10.2 | Patch available | GHSA-774q-r975-vqwp |
| — | mayan-edms (PyPI) | 4.9.0 to before 4.9.7 | 4.9.7 | Patch available | GHSA-774q-r975-vqwp |
| — | mayan-edms (PyPI) | 4.8.0 to before 4.8.10 | 4.8.10 | Patch available | GHSA-774q-r975-vqwp |
| — | mayan-edms (PyPI) | 4.7.0 to before 4.7.8 | 4.7.8 | Patch available | GHSA-774q-r975-vqwp |
| — | mayan-edms (PyPI) | before 4.6.12 | 4.6.12 | Patch available | GHSA-774q-r975-vqwp |
- EDMS VendorMayan Affected 4.10.0; 4.10.1 Fixed in 4.10.2 Patch available CNA
- mayan-edms (PyPI) Vendor— Affected 4.10.0 to before 4.10.2 Fixed in 4.10.2 Patch available GHSA-774q-r975-vqwp
- mayan-edms (PyPI) Vendor— Affected 4.9.0 to before 4.9.7 Fixed in 4.9.7 Patch available GHSA-774q-r975-vqwp
- mayan-edms (PyPI) Vendor— Affected 4.8.0 to before 4.8.10 Fixed in 4.8.10 Patch available GHSA-774q-r975-vqwp
- mayan-edms (PyPI) Vendor— Affected 4.7.0 to before 4.7.8 Fixed in 4.7.8 Patch available GHSA-774q-r975-vqwp
- mayan-edms (PyPI) Vendor— Affected before 4.6.12 Fixed in 4.6.12 Patch available GHSA-774q-r975-vqwp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mayan-edms:mayan_edms:*:*:*:*:*:*:*:* | before 4.10.2 | Vulnerable | Mayan EDMS |
- cpe:2.3:a:mayan-edms:mayan_edms:*:*:*:*:*:*:*:* Versions before 4.10.2 Vulnerable ·Mayan EDMS
Remediation
- Fix · CNA EDMS (Mayan) Fixed in 4.10.2
- Fix · GHSA-774q-r975-vqwp mayan-edms (PyPI) Fixed in 4.10.2 Advisory →
- Fix · GHSA-774q-r975-vqwp mayan-edms (PyPI) Fixed in 4.9.7 Advisory →
- Fix · GHSA-774q-r975-vqwp mayan-edms (PyPI) Fixed in 4.8.10 Advisory →
- Fix · GHSA-774q-r975-vqwp mayan-edms (PyPI) Fixed in 4.7.8 Advisory →
- Fix · GHSA-774q-r975-vqwp mayan-edms (PyPI) Fixed in 4.6.12 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-14691
- 2026-10-03 Alias added: GHSA-774q-r975-vqwp
References
Patch 2
Other 5
- https://github.com/mayan-edms/Mayan-EDMS
- https://github.com/pypa/advisory-database/tree/main/vulns/mayan-edms/PYSEC-2025-134.yaml
- https://gitlab.com/mayan-edms/mayan-edms/-/commit/45355cbb45a28f61f38f719112d0ff422e6dc688
- https://gitlab.com/mayan-edms/mayan-edms/-/commit/94032fbe553e97b33e4e9b9e731b4fc45f9d9f91
- https://gitlab.com/mayan-edms/mayan-edms/-/commit/da9de60a9b84f11d5d2c7bbf118fe696b4f6357e
More Mayan Edms vulnerabilities
- TI-2022-23496 Mayan EDMS Tag XSS CVSS 3.1MEDIUM 5.4
- TI-2025-13414 Mayan EDMS authentication redirect CVSS 4.0MEDIUM 5.3
- TI-2018-11759 An issue was discovered in Mayan EDMS before 3.0.3. CVSS 3.0MEDIUM 6.1
- TI-2018-11758 An issue was discovered in Mayan EDMS before 3.0.2. CVSS 3.0MEDIUM 6.1
- TI-2018-11757 An issue was discovered in Mayan EDMS before 3.0.2. CVSS 3.0MEDIUM 6.1
- TI-2014-03118 Multiple cross-site scripting (XSS) vulnerabilities in… CVSS 2.0LOW 3.5
Sources
- CVE-2025-14691 · CVE Program
- CVE-2025-14691 · NVD
- FIRST EPSS
- GHSA-774q-r975-vqwp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences