Read the docs
TI-2022-23814 Aliases CVE-2022-48115GHSA-q82h-q47j-f492

The dropdown menu in jspreadsheet before v4.6.0 was discovered to be vulnerable to cross-site scripting (XSS).

Priority MEDIUM 60CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

The dropdown menu in jspreadsheet before v4.6.0 was discovered to be vulnerable to cross-site scripting (XSS).

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00411 35th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed jspreadsheet-ce (npm): 4.6.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—jspreadsheet-ce (npm)before 4.6.04.6.0Patch availableGHSA-q82h-q47j-f492
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • jspreadsheet-ce (npm) Vendor— Affected before 4.6.0 Fixed in 4.6.0 Patch available GHSA-q82h-q47j-f492

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jspreadsheet:jspreadsheet:*:*:*:*:*:*:*:*before 4.6.0VulnerableJspreadsheet
  • cpe:2.3:a:jspreadsheet:jspreadsheet:*:*:*:*:*:*:*:* Versions before 4.6.0 Vulnerable ·Jspreadsheet

Remediation

  • Fix · GHSA-q82h-q47j-f492 jspreadsheet-ce (npm) Fixed in 4.6.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-48115
  2. 2026-10-03 Alias added: GHSA-q82h-q47j-f492

References

Sources